Jump to content
Corsair Community

Corsair 860AXi Self-Test Does not work, but motherboard receives power?


Recommended Posts

Hello! So, I am finally getting around to putting my brand new PC build together. I have run into something strange... here it is:


TL;DR version: The self-test button results in only a click happening, but when plugged into the motherboard it seems to receive power just fine.


Details: I started to hook in my PSU, but then noticed it has a self-test feature. So, I plugged it in to the wall and before hooking up cables, tried the self-test. Nothing, just a double-clicking PING and no light/fan spin up. Thinking I would surely have to RMA, I began the process...


But after talking to a friend, he recommended testing it with the motherboard anyways, as it really shouldn't damage anything. I don't have my CPU thermal paste yet (that gets here tomorrow), but even without the CPU in I should be able to tell if the motherboard gets power and such. So, I tried that and viola! The motherboard powers on, the power supply gives a green-light in the self-test LED, and the fan spins up. The motherboard is of course giving me a CPU-LED error, but it should, there isn't a CPU in it.


So, what does this mean? Is it possible that the self-test button itself is the faulty part, and I should go ahead with the full build tomorrow and see if it posts? I really don't want to go through a 2-week+ long RMA process... especially if all of the important components of the PSU works!


Thanks for your help!


Link to comment
Share on other sites

It's possible the self test itself failed.


Thats up to you if you want to return it or not. Since it's a new unit, i would start with your reseller first and have them exchange it for you. If they can not or will not help , then go through the RMA procedure.


You can always ask for an advanced replacement if you need to

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...