Jump to content
Corsair Community

Force 3 120GB Gone - Please help me.


Recommended Posts

Hello everyone.


First, i'd like to say how much I really like Corsair. I've build my computer with as much from Corsair as they got. Case, memory, water cooling, SSD and power supply, and I absolute love it!


Yesterday, I was playing Battlefield 4, and my sound went off, and a few seconds later, I got the bluescreen from Windows 7 (Haven't seen one of those in years), and the computer had to restart.


After the restart, the bluescreen happened again a short time later, I restarted again, and after that, my BIOS wasn't able to find my SSD anymore. I turned it off, and let it cool off for a bit, and think what it could be.


But i've tried pretty much everything, and i'm really afried that it might be dead, and it's only 371 days old.


I did the power cycle thing, where I let it be on for 30min, and retart without touching it, and so on. I tried to do the firmwire update, but none of the programs that I from the stickes, could even find my SSD Force 3 120GB, so I wasn't able to update my firmware.


I did read all the stickes, and more than once, but I haven't found one that was on a stupid enough level so I could understand it.


I really hope that someone can help me here, thanks a lot!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...