Jump to content
Corsair Community

M95 - Sensor is not tracking.


Recommended Posts



I was at a LAN-party and bought a M95 mouse at a booth. I quickly returned it becuase it was DoA. It didn't react at all when it was connected to a computer.


I got it replaced, and it worked just fine.


There were some issues with a game, so I had to restart my computer. When I turned it on, the mouse LED's turned on, the mouse-buttons are working, but it's sensor is not tracking.


I've tried the following:


Reinstall driver

Firmware update

Try 2 other computers

Using both USB 2.0 and 3.0.



Does anyone have any suggestions? I am really tired of this mouse already..

Link to comment
Share on other sites

It sounds like the sensor is bad. Request an RMA to replace the mouse. I would also contact customer service and ask if they can provide a pre-paid shipping label as the unit is less than 30 days old.


You can call customer service using Skype by calling their toll-free number.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...