Jump to content
Corsair Community

Corsair Force 3 Series GT SSD Suddenly stops to work on my MB.

Recommended Posts



I have a MBP8,1(13' inch - early 2011), and after using my Corsair Force 3 Series GT SSD 120 GB after about a year, it suddenly stopped to work. The OSX don't detect it anymore on this machine.

- When i try to boot it gets really slow, and the kernel message says that "root device is not found".

- When i go to the recovery mode and try to format the disk utility freezes.


I tried to put it on another MBP, it worked fine, only on my machine not working. When i put on a USB case it work fines too. After all i had to put my old HD sata back. but its really pissing me of, i want my SSD back.


What should i do?


- I've tried to update the firmware loading on a windows with a USB case and run the ssd toolbox, but it cant update the firmware. The current firmware version is 5.02.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...