Jump to content
Corsair Community

Is my SSD dead?

Recommended Posts

I have a pre-built computer, and it's getting slow. I'm pretty fluent in computer (but I don't have much money), so I decided to buy a refurbished Corsair F120 120 GB SSD for $60.


I used a couple of tools to migrate my OS from my 1 TB HDD to the SSD, and when I booted it up for the first time, it worked great; it was super fast, and I had no compatibility issues. I played a couple of games, and it worked great, until I turned it off so I could boot from my old HDD in order to find some settings I had forgotten.


When I restarted the computer to boot from the SSD, it booted from the HDD. I had set the boot order to SSD first, so I thought that was a bit weird. I restarted again, and went to manually boot from the SSD in the UEFI menu. It was not there. I went into the BIOS and the SSD was not there under storage.


I restarted again, and this time, after going into the manual boot settings, I was able to boot from the SSD again. I chalked it up to a loose cable, so I turned it off and adjusted the cables, and then booted it back up and it went straight to the SSD, so I thought nothing of it.


I installed it 2 days ago, and anytime I've needed to boot from the SSD, the BIOS refused to recognize it until I restarted a few times. I figured something was loose, and since the warranty has expired (probably), and it was only $60, I figured I'd just have to deal with it, since it had been booting after a few restarts...


...Until last night. I woke up and couldn't go back to sleep so I went downstairs and did some late night gaming. It was the same old story: It took a few tries, but eventually it booted up. I got a solid hour of gaming in before my game froze. My mouse could move, so I figured the game had crashed, and pressed the Windows logo so I could get to the start bar to open the task manager. The start bar came up on top of my game, but the Start Menu did not. When I attempted to click on it, it gave me the white hourglass of doom. I could move the FRAPS window around on my second monitor, so I thought it was just a major hang-up. Boy, was I wrong. I waited 10 minutes, to no avail. I did a hard reset. The computer booted to the HDD, again.


I attempted to boot from the SSD again, and after a few tries, I got it to work. Then, after 2 minutes, the same situation happened again: a total freeze-up.


I did the above once more, with the same results. I then attempted to boot again, but had no luck, and this time I mean, absolutely no luck. The BIOS refuses to acknowledge the existence of the SSD, and I've tried everything. Booting to the HDD reveals nothing.


I checked my BIOS settings, and SATA emulation was set to AHCI, just like it should be. I checked cables, they appeared to be fine also.


I know that SSDs have a finite number of writes they can sustain before they conk out, but this SSD is not that old, at least from what I can tell.


So, the big question, is it dead? Did I do something wrong? Is it fixable?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...