Jump to content
Corsair Community

Is this a FORCE 3 issue or something else?


Recommended Posts

I have a Corsair FORCE 3 64Gb SSD on which I have installed Windows 7 (64bit) . Specs as above. All amazingly fast until recently when I started getting APPCRASHs and BEX issues - browsers (all of them) crashing out, Windows Explorer failing over and over and restarting, programs like Notepad and Paint failing. Browser failure is often triggered by starting to type.


So, multiple AV scans later, Windows Update, Drivers update, every stress test and hardware tool you can think of, removing main graphics card...blah blah blah, I am coming to the conclusion it must be the mobo or the SSD.


Hard Disk Sentinel shows a nice graphic which shows why I think it's the SSD and I'd be grateful for your opinion: The Raw Read errors don't look pretty - normally the figure is 120 so this test was lower than normal.


I did the overprovisioning thing having resized the Windows partition to make room for it and ran TRIM - the firmware won't update as I did that when I received it and there are no newer releases. The ATTO score shows a mild speed improvement, which is nice.


However, I am still getting these issues. I have removed Acronis, done the DEP thing but no joy. I am suspecting it might be the SSD is having difficulty.


Really frustrating - I love the speed of the SSD but I don't know where to go from here.


Any suggestions please?




Link to comment
Share on other sites

  • Administrators

The toolbox can't update the firmware on a drive that has 1.x firmware on it. You can update it to 5.05 manually using this tool:



Afterwards re-run the tool and see if there's a newer update for your drive.


Have you secure erased it and reinstalled windows, or tried it on a different SATA port?

Link to comment
Share on other sites



No, I haven't secure erased it (is this to reset the drive to "empty"?); was hoping to avoid a rebuild if possible. So haven't re-installed Windows yet either, again, hoping to avoid that if possible.


I haven't tried a different port either. That might be relevant if it's a mobo issue I think so will stick that on the troubleshooting list.


However, I have followed your instructions! Curiously, having upgraded the firmware manually to 5.0.5, the Corsair SSD Toolbox tried to revert to 1.3.2. I don't think it actually did this, just what the GUI was reporting. HD Sentinel reported the right version. Interesting to see the increase and decrease of max read and max write.


On reboot, icons took their time to redraw but so far none of the browser issues have arisen. Fingers crossed!



Link to comment
Share on other sites

  • Administrators
The toolbox can't revert to 1.3.2. Also, shutdown and turn the system back on and the toolbox should show the SSD as having FW 5.0.5. I'd only recommend looking at the SMART data from the toolbox. The drive is also already over-provisioned when it's at 60 GB, so you don't need to over provision further (but it won't hurt anything).
Link to comment
Share on other sites

Yes, I think the GUI just had " a moment". :roll:


Can you tell me how much the 60Gb is overprovisioned please? Just curious, although 1Gb extra seemed to improve things.


Finally, as things seem stable now I am planning for a Windows re-install as you recommend, just to clear out any doubts over software. I was thinking of using my mobo's Intel Rapid Storage Technology with a Seagate Hybrid drive (1Tb + 8Gb NAND SSD) and the existing Corsair Force 3 60Gb SSD. I understand that setting the drives as a RAID array in the BIOS will allow this technology to use the Force 3 SSD as a huge "cache" and therefore improve the speeds of the HD alone (although not as fast as I have now). This should ensure any SSD issues aren't critical (I can break the array) and means I have 1Tb to play with, not 60Gb. My question is really, what do you think might happen given that the hybrid drive does something similar internally with its 8Gb NAND? Can you foresee any issues? And should I use the secure erase function as you mentioned please?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...