Jump to content
Corsair Community

Corsair M90 hardware playback not working


Recommended Posts

Hi, I noticed that my corsair hardware playback was not working. I think it's bricked for some reason.. All the profile lights are up even if my profile 1 and 2 arer set on light 1 and 2, tried reinstalling drivers with reboots, nothing worked and when I try to do the firmware update to 1.12 windows stops recognizing my mouse in the process at step SET FIRMWARE UPDATE MODE! I have to uplug/replug my mouse to make it work again

mouse is in usb 2.0 port and chipset drivers are installed.



USB Mouse:

VID: 0x1B1C

PID: 0x1B31

Manufacturer: Corsair

Product: Corsair Vengeance M90 Mouse

Firmware: 1.11

Windows: Windows 8.1 Pro 64 bit


Please Help,

Thank you

Link to comment
Share on other sites

I already have them but it looks like my profiles are not in the mouse because when I enable hardware playback my two buttons that i usually use to switch profile become the 2 buttons to ajust dpi wich is the default mouse macroes, and i saved my profiles to the M90
Link to comment
Share on other sites

I think it might be the software being newer as you have an older firmware.

http://www.corsair.com/media/cms/drivers/M90update1.0.0.29.zip - FW 1.11/SW1.0.0.29


Have you tried updating the firmware on another computer? Does it work?


Do you see the 0-100% next to the Save to M90 button after clicking it?

If no, Check and see if M90hid.exe is running in Task Manager. If it's not running go to the install folder and double click the .exe.


For the profile lights, After saving and enabling hardware playback. Press the Profile Down button. Does it move down?

Link to comment
Share on other sites

  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...