Jump to content
Corsair Community

M90 stopped working / lights flashing


Recommended Posts

Hey there. I've been using an M90 for about a year now. It's by far the best and most comfortable mouse I've ever used. I figured out the bindings and the macros, and I just love the mouse. Only complaint is that about 30% of the time, the mouse is dead when I boot up my computer, and I have to go under my desk, unplug it, and plug it back in. It always worked after doing that though.


However, today the mouse was dead but when I plugged it back in it still didn't work at all. For the first time ever though all of the lights on the mouse are blinking at about a half second interval. The only light not blinking is the mouse profile light, which is lit steadily at "profile 1". Can anyone help me? I've unplugged it for a while, and tried different usb ports.



Link to comment
Share on other sites

Update - Today I plugged the mouse in and it worked like normal, so I wanted to do everything I could to fix it while windows was recognizing it. I found a working link to reflash the mouse, and I did it. It went through the process, the mouse went out and in of functionality, and finally it said "firmware reflash successful!" and right as it finished, the lights started flashing again and the mouse lost all functionality, just like before.


Any ideas? Or anything for me to try the next time the mouse works? It seems like if time goes by my system might recognize it again. I've tried the mouse in every USB port, by the way. And I have never had a problem with any other device on my system.


Please let me know if there's anything you can think of...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...