Jump to content
Corsair Community

Vengeance K90 top/number row issue


Recommended Posts

I just got my refurb K90 delivered today. Everything seems fine, except for the fact that the top row of keys type both the letter and the number of the number key above. For instance, the sentence "Help, my keyboard isn't working!" types out as: W"He3lp0 my ke3ybo9ar4d i8sn't w2o9r4ki8ngQ!W"


The number row also does this. For instance, pressing 1 results in q1 being typed.


I'm running the latest software. Is there anything I can do, or is my keyboard just broken?

Link to comment
Share on other sites

Okay, I have no idea what happened now.


I tried it yesterday, updated the firmware, restarted the computer, plugged it back in etc. to no avail. Today I figured I'd try it on another computer before returning it and found that it worked perfectly. After that worked I plugged it back into my main PC and found that it now works fine on that too. Bizarre.


Thanks for the advice. Looks like things somehow fixed themselves.

Link to comment
Share on other sites

  • 4 weeks later...

I have a similar issue, everything on the keyboard works except 1,2,3,4,7,8.

5,9,0,-,= and backspace all work fine, playing fps are impossible without the 1234 keys. i have tried to update the firmware multiple times. Any help would be appreciated.

Unfortunately i do not have another computer to try it on.

Link to comment
Share on other sites

You can try BIOS mode and back to see if that fixes it.


Add BIOS/Standard Mode standard mode


Standard Mode usage


BIOS/standard Mode Description

For compatibility with system BIOSs without gaming keyboard support and certain security driver software, K90 v1.36, K60 v1.34 support so called “BIOS mode” or “Standard Mode”. This mode disables for K90,K60 all “Gaming Mode” features and making it work keys like standard USB keyboard.

For example in “Standard Mode” the K90 G-Keys and K60,K90 N-key rollover are disabled.


Important Note: Standard mode is persistent, when Standard Mode is active on re-plugging the keyboard or restarting the system Standard Mode will still be ON.


BIOS/Standard Mode usage


To enable Standard Mode:

Press WinLock + F1 keys together

Indicator Standard Mode is active :

Scroll Lock LED blinks


To disable Standard Mode:

Press WinLock + F1 keys again

(Scroll Lock LED stops blinking)

Source: K90 Firmware release notes.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...