Jump to content
Corsair Community

HELP! H60 Pump only at 1400 rpm!


Recommended Posts

Hey guys, ive had a corsair h60 on my custom built rig for about 1.5 years now.. the other day i booted up and realized i have a cpu heating issue.. long story short, my pump is only running at 1400 RPM no matter what i try to do :( My pump is connected to the pwr_fan header, my radiator fan is connected to the CPU_Fan header, ive tried all the tricks in my asus bios and simply CAN NOT find a solution.. please help! Ive re-applied the thermal past twice now, fully dusted my machine, tried multiple different header connections and im basically at a loss here guys, so input would be GREATLY appreciated.


My cpu is running around 40-50 Celsius idle, and easly jumps to double that under any kind of mild load. Ambient temp is around 74 Fahrenheit. Is my pump failing? or is there something that has happened to cause this?? I didnt do anything to cause the random sudden problem... had to un-overclock my machine just to let it boot up.. again pump RPMs are running 1450 TOPS.. I was under the assumption pumps either worked or they didnt, but i may be wrong. I bought a H100i anyways but I'd like to be able to use my machine for more than browsing til it arrives.




Link to comment
Share on other sites

Yes, it would and sometime depending on the case load they have it may take longer than the 24hrs they say it will. But they answered in the order they are recieved.


You could always call and they would be able to assist you on the spot. Or even the Live Chat option.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...