Jump to content
Corsair Community

Problem experienced while updating from 5.03 to 5.05 via the Toolbox- Has it worked?


Recommended Posts



First a quick overview


I have a GT 240GB drive (which is configured as my main system drive). Last year I used the Firmware Update tool to successful update the firmware to version 5.03 with no problems.


This time around, I decided to use the Corsair SSD toolbox to update the firmware to 5.05. The firmware downloaded correctly, but at the end of the firmware update process the Toolbox stated that an error had occurred and that it could not update the firmware. No error code was produced – so I am none the wiser about what happened!


As a precaution, I had backed everything up beforehand, and expecting the worst I rebooted the system. You can imagine my surprise when the system booted up correctly (with no warnings) and the toolbox reported that the SSD was now at 5.05.


To test, I ran the Trim command via toolbox – no problem reported and I checked the version of the SDD firmware via Intel’s RST + other disk info programs => all reported back 5.05. Corsair’s Toolbox reports that the firmware is up-to-date and no further action is required.


Although I can access the drive via the Corsair's SSD toolbox, however, when I tried to access the SSD via the Corsair’s Firmware update tool (v1.1), the drive is no longer visible!


I haven’t experienced any instability (yet), it’s only been a couple of hours, but I would like to know (if possible) what has happened and if trouble is ahead.


My Questions at this stage



  • Has anyone experienced this behaviour before? Do I have a problem?
  • Has the SDD been updated successfully? Is there a way I can really confirm what the system reports is correct and that there is no firmware corruption?
  • If I’m unsure, is there a way I can reapply the firmware update again without destroying the SDD’s contents?
  • Also, should Corsair’s firmware update tool report back that the drive is at 5.05 and does anyone know why it does not show the SDD drive anymore?


Thanks in advance,



Link to comment
Share on other sites

I've had similar results with the update tool saying that there was an error but the f/w on the drive was, indeed, updated. I have learned to live with this sort of failure and haven't experienced anything negative w/r the drive performance.
Link to comment
Share on other sites

Thanks for the response, JKeifer. It makes me wonder if the software tools we are provided with are any good! :[pouts: I do hope the Trim utility works.


After some further research, I upgraded my Intel RST driver from to (which controls my SATA controller)-> and the SDD reappeared again on Corsair's Firmware Update Tool. I reapplied the firmware update again using this tool to be safe and it worked this time (the magic green tick appeared).


Overall performance is slightly slower, but that might be due the Intel update. Hope this was the correct course of action.


Can anyone confirm that the below performance is acceptable for a GT 240MB? Please see attachment.


Link to comment
Share on other sites

Thanks for the quick reply. :biggrin: FYI - the SSD was about 5% faster before the Intel update. :(:


What is causing me concern is the firmware update issue, can anyone confirm if my approach was correct?


Thanks again in advance.

Link to comment
Share on other sites

OK - Just to confirm that I understand you comment correctly and its implications.


You can update/overwrite the same firmware version multiple times if you experience problems. Is that correct?


My finally question (I hope I'm not been too greedy), given what happened (i.e. failure to update the firmware via toolbox), is there a documented test process available to confirm if the firmware update is successful?


I would like to say thank you - Technobeard - for your help so far.... That name/image brings a smile to my face :rofl: - can't help but think of the stoning scene from the Life of Brian. I hope that comment is not too controversial.






Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...