Jump to content
Corsair Community

2 x CSSD-F120GB3 not detected


Recommended Posts


Sorry for my english i'm from France...


-My first SSD F120 worked well for 1 year and 6 months

-it was a CSSD-F120GB3A, it was suddenly not recognized in bios

-So i created a RMA,

-CORSAIR sent me a new SSD: CSSD-F120GB3-BK

-I installed windows 7 on this new ssd

-24 hours later it was again not recognized in bios...


So I wonder what's wrong with the SSD? Knowing that I have 4 other drives in my pc, and they work very well !!!


I tried many SATA cable, and an other PC. This SSD is not detected again !


So i created new RMA ......................

Link to comment
Share on other sites

Contact customer service via phone and tell them that the replacement drive is faulty. The rep. will help you or in your new RMA tell them the drive has been replaced before and provide them with the previous RMA in the comments section.


You can call them using Skype by calling their toll-free number on their website.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...