Jump to content
Corsair Community

Botched Update of Corsair Neutron SSD


Recommended Posts

Current Firmware version reads as M206. An attempt to update it on a Windows 8 x64 system failed, leaving the drive unbootable although I can access all of the files on it.


Further attempts to update the firmware don't work. I've tried a different Windows box, and I've attempted to secure erase the drive (which does work); but the drive cannot be booted from, nor can I update its firmware - it just works as a secondary drive.


I have other Corsair drives (a few Force, a couple of other Neutrons) across my network, they all updated flawlessly so this is one drive out of 18 that's decided not to cooperate; but it's a drive that just came back from Corsair RMA. I'd rather see if I'm missing something obvious before I reply to the ticket with 'yo I got the drive... and it's broken now' - any ideas?


Have tried;


- Latest AMD chipset driver for AHCI/SATA.

- Standard Microsoft drivers for AHCI/SATA.

- Wearing a necklace made of Garlic.

Link to comment
Share on other sites

Okay, never mind. My roommate got frustrated and hit the drive and slammed it into the top dock of my case with significant force. Now the firmware update worked and it seems fine. So apparently, the solution was violence.


(I don't recommend anyone else do that.)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...