Jump to content
Corsair Community

Corsair H80 - unable to change fan speed? help please!


Recommended Posts



I've just installed a H80 and it's very loud, when I press the digital fan speed button on the block, nothing happens, the light changes but the fan speed does not. Any idea why that would be?


I've tried plugging the cooler into the CPU_FAN and CPU_OPT inputs but that makes no difference. The fans are plugged into the CPU block as per instructions.


The fans are running at 2100 RPM and cpu is 25 degrees.


I'm using a i5 4670k and Gigabyte Z87-D3HP


I have tried resetting firmware as per instructions here:


1. While the computer is running, hold down the profile button for approximately five seconds

2. Wait one minute, while the unit continues to run

3. Shut down your computer

4. Press and hold the profile button for five seconds while turning on the power to your computer.


But it made no difference.


Please help!

Link to comment
Share on other sites

you could attach the fan's at your motherbaord and get them silent, if they don't get silent, you'll have some bad fan's.

If it helps, then your fan controller of the H80 is faulty and you should report this to tech support and ask for rma.


Thanks. I've plugged the fans directly into the motherboard and now it's near silence! Such a huge difference.


It must be that the fan controller on the H80 is faulty, not sure whether I can be bothered to RMA it for that though :p

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...