Jump to content
Corsair Community

m95 software problem


Recommended Posts



I have this problem where none of the changes i make in the software will go over to the mouse nor will the surface quality test work. This worked the first time i installed it and it worked after i had re installed the program and ran a firmware update on the mouse, but after that whenever i restart the pc the software wont apply changes again.


I also have the problem that if i try to do a firmware update while connected to a usb 3.0 port it will lose connection and i have re fit the usb cable.


Thanks in advance

Link to comment
Share on other sites

Post the information that is displayed in the information pop-up. (Click the little "i" icon at the top right hand corner)

What changes are you trying to make? DPI changes, button assignments?


I would recommend you plug the mouse into a USB 2.0 port to update the firmware.

Link to comment
Share on other sites


usb mouse: VID 0x1B1C PID 0x1B06 Manufacturer: Corsair, Product corsair vengeance m95 mouse, fireware: NA, windows 7 home premium 64 bit


and i did plug it into the usb 2.0 and updated the firmware and installed the software again when i did it. It worked fine then and stopped working again when i restarted my pc.


The changes i have tried is key assignments, dpi, light, adding a new profile to the mouse and none of those work

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...