Jump to content
Corsair Community

Ticket 6120603, Please help.

Recommended Posts

I have just purchased a voyager air. I have had it on charge via the eu charger for nearly 2 hours. I then plugged the usb cable in and then to the pc. Turned the power switch (Still plugged in to the power) The drive powered on for about 5 seconds before all lights go off! The only way to get lights on is to unplug the cables and reinsert. Please help!



Have just tried it again. Plugged the power cable in. Nothing happens, no lights or anything. Then plugged the usb cable in aswell and plugged it in to the pc. Then the amber light came on and the 'lightening bolt' came on. Turned the drive on, the power light came on for about 3 seconds, then went off, the other two lights then turned off after about 1 second.

At no point has the pc even 'seen' the drive in explorer.

I am running a laptop with usb 2 and 3 ports. Doesn't work on either. Have also tried my wifes pc. Nothing.

Even if i turn the drive on with nothing plugged in, nothing happens.

PLEASE HELP. I was soo looking forward to this drive. Do i need to return it to the supplier for a replacement?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...