Jump to content
Corsair Community

Brand new V2000 solid amber light straight out of the packet


Recommended Posts

I picked up my 2nd pair of V2000's today after RMAing the first pair due to the cracking issue.


Upon unboxing my brand new pair I put them on charge and got a solid amber light straight off the bat.


I have tried multiple usb ports and still the same thing.


My first pair worked flawlessly and am pretty pissed that these ones seem to be dead on arrival.


Is there any solution to this problem or do I have to RMA these ones too?

Link to comment
Share on other sites

Let the battery drain and fully recharge it before using it again.


The thing is they never charged in the first place and do not turn on at all however, I did not plug them in at all on Saturday and have just plugged them in again on Sunday evening and it still just sits on a solid amber light.


Thanks for trying to help mate.


Guess I will have to wait for either a Corsair rep to give me some advice or I will have to wait Tuesday our time for a response to my ticket.

Link to comment
Share on other sites

Unfortunately a DOA product happens from time to time with any product. There isn't anything you can do to fix it and Corsair would have no idea why they failed without a detailed analysis.


Since you just bought them it would be best to return them to your resellers first. If they can't or are unwilling to help , the please use the link on the left to request an RMA.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...