Jump to content
Corsair Community

Corsair GT 120 GB Won't update


Recommended Posts

  • 2 months later...
  • Administrators
Same exact issue here.


Running Toolbox 1.1. Am unable to update either my Force GT 120GB or Force GT 90GB.


Please take a screenshot of the toolbox showing the signature as well as the error screen, and then post it here.

Also, please fill out your specs in your profile.

Link to comment
Share on other sites

You need to update the SSD firmware using the field updater tool (manual updater) to 5.X as the SSD toolbox does not support FW updating from 1.3.X to 5.0.X.




Thank you for this. I was able to update my Corsair Force GT 90GB to firmware 5.05, however the Corsair Force GT is not updating with the SSD Firmware Update Tool - simply nothing is happening. It's putting the checkmark to say the firmware has downloaded to the drive, I close the application and re-open it and do a new Rescan For Drives, and firmware 1.3.2 remains.



Link to comment
Share on other sites

No I can't say I have tried a different SATA port. The drive works fine on the current SATA port, would not imagine a different one would be needed.


Edit: Just tried it again, and it worked. Not sure what was going on yesterday that would prevent it from working, but it does now. Odd! Need a more elegant solution to get these things upgraded I think, for the future.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...