Jump to content
Corsair Community

A Scary Moment, with a Happy Ending


Recommended Posts

I have a system (Windows 8, ASUS Sabertooth 990FX R2.0, AMD FX-8250, AX-860i, H100i, Commander 2, Cooling Node, Lighting Node, 32GB G.Skilll Ripjaw, 500R, etc.) that is operating properly with the Link Commander and Software.


Initially Corsair Link did not see the Commander, but I followed Toasted's procedure to update the Commander Firmware to 2.0.6 using Link 1.2.7 on a Windows 7 System and now all devices work with Corsair Link under Windows 8.


Occasionally, when Corsair Link opens at boot there are duplicate devices (H100i, Fans, etc.) showing with no readings, but deleting the erroneous devices returns everything to "normal".


The reason for the thread title is that I've just built a duplicate system in an Air 540 Case. Upon installation of Windows 8 and then Corsair Link version 2.4.4948 I again did not see the Commander.


Instead of using one of my Windows 7 Systems to upgrade the Firmware on the Commander, I uninstalled Link 2.4.4948, deleted all related folders in the Programs and User (profiles) areas, did a reboot and then cleaned the Registry.


I loaded Link 1.2.7 and could see the Commander to do a Firmware update. When I clicked on the START button for the update, the addresses which were being written counted up on in the window, and then stopped. Neither the START or CLOSE buttons could be selected, the Link Program was "Not Responding", and I was certain that I had bricked the Commander. I let it set for 30 minutes, and then used Task Manager to end the Link 1.2.7 processes.


I uninstalled Link 1.2.7, related folders and profiles, did a reboot and cleaned the Registry. I then re-installed Link 2.4.4948 and WALA, the Commander was listed under devices with Firmware 2.0.6.


Waiting for a Lighting Node (due in two days) but everything else is operating great, so a happy ending.



Link to comment
Share on other sites

Hi wa3pnt,


Could you explain what you did when you cleaned the registry?


I have an issue that Corsair Link no longer detects my H80i.


I have tried removing the Link software, the USB driver for H80i and the profiles / remaining Corsair directories but to no avail....



Link to comment
Share on other sites

Registry cleaning is easy. Install a program like Ccleaner and run the registry part.


You should run it al least once a week if you do allot of installing or delete files and folders


That's exactly what I use. Very easy, and cleans up a lot of things that remain when various items are removed.



Link to comment
Share on other sites

  • 2 weeks later...



I've installed CCleaner and must admit to being too scared to press that button as it doesn't appear to be picking up the error I was expecting.


I started having problems with the H80i not being detected by Corsair Link after installing a M90 mouse that was faulty.


Since then, the H80i appears in the Win7 devices list as an Integrated USB bridge (as it did before) but Link will not pick it up - There have been a couple of occasions when I have managed it after uninstalling the USB bridge device but it has only lasted a short time before disappearing again.


Tried connecting the H80i on my other internal header and still the same result.


I think that there might be some corruption of the registry and was hoping that an entry could be deleted and presto! it would all be alright again.....


Should I search for all entries that refer to the m90 and H80i device and delete them?


Any advice would be appreciated as usual.



Link to comment
Share on other sites

If you use CCleaner, and scan the registry for issues, you can select which items are deleted from the registry when you "Fix selected issues". Just check what you want to remove and uncheck everything else.


So you could look for any issues associated with Corsair, H80i, or M90.


Also, CCleaner prompts you to "Save anything that you delete from the registry" before actually deleting it. Just make note of where you save the items (I save them in the Folder in which the CCleaner installation programs are located). You can then restore anything removed by double clicking on the saved file.


I have been using CCleaner for years, and have never had a problem where I needed to restore an item that was removed.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...