Jump to content
Corsair Community

Voyager Air dead after firmware update


Recommended Posts

I ran through the upgrade guide to update to the latest 1.2.7 firmware on my Voyager Air, the system responded as normal with the wireless light flashing for around 5 minutes, the light stopped flashing after some time and now the drive is unreachable.


I left the drive for around 2 hours before trying some other methods of recovery, I tried the reset button and also tried connecting via USB however the drive no longer appears.


Is there a way for me to hard reset the device, or reflash the firmware, or is this an RMA issue?


Many thanks.

Link to comment
Share on other sites

  • 3 months later...

Sorry to bring up an old thread, but I'm in a similar situation. My Voyager Air died (not after firmware, just turned it on a few days ago and I can't read anything off the drive).


To submit an RMA ticket Corsair requires you to select the product family and product series. I can't find Voyager Air in any of the categories... So how exactly do I submit an RMA ticket for it?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...