Jump to content
Corsair Community

K50 faulty?


Recommended Posts

Not really sure why I continue to bother with Corsair products.


I just plugged in my brand new sealed box K50 keyboard and the 3 lights are flashing (Scroll, Num, Caps).


I can't update the firmware either. This is the fourth Corsair product I've purchased which has been faulty out of the box.


Running Windows 8 and tried everything I can think of. Unless this keyboard requires a system format I'm not sure why it won't work. From what I can see the flashing lights is a bios mode, but the K50 has not bios switches.


Any help or advice?

Link to comment
Share on other sites

Reported Data:



USB Keyboard:

VID: 0x1B1C

PID: 0x1B04

Manufacturer: Corsair

Product: Corsair K50 Keyboard

Firmware: NA

Windows: Windows 8 Pro 64 bit


When I try and update firmware:


Cannot open USB device, please plug the device into a USB port or reinstall driver!

Link to comment
Share on other sites

  • Corsair Employees

Hello Tonemapped,


Have you tried plugging it into another computer to see if it does the same thing? I apologize that you were not able to reach Tech support. If this unit is faulty, we will be more than happy to replace the unit for you.

Link to comment
Share on other sites

- Tested on two entirely different computers (Windows 8)

- Updated all drivers

- Phoned tech support, told to update drivers by John and even try Windows 8.1

- Tried Windows 8.1 - same result

- Formatted and tried Windows 8 again


I don't really think there is anything else I can try. If a product says it's for Windows 8 and only works on some set ups then it's not for Windows 8. My motherboard on this main PC has update drivers etc and features a 'Windows 8 Ready' logo. No other hardware has an issue with it.


I've ordered another K50 and will test it on Windows 8 and 8.1 - if the same result occurs then I suggest you remove the 'Windows 8' under compatible Operating Systems.


PC1 Spec:


i5 3570K

ASRock X68 Pro3

16GB Corsair DDR3


Radeon 6990



PC2 Spec:


Lenovo Q180

ATOM D2700


USB 2/3

Link to comment
Share on other sites

After spending many hours, formatting three times, buying another keyboard (an extra £12 postage) and £11 on phone calls (US-based phone support only from Corsair), I have managed to get the keyboard working.


The current keyboard is still faulty as the spacebar is not even, the right side needs pressing in hard and the left taps easily. However at least it works in W8.1. I'm now going to put W8.0 back on this PC and see if it still works.


Overall I'm really not impressed. This is the fourth item I've purchased from Corsair (excluding RAM) that has not worked as I would expect it to (plug in->install driver->works), or has been damaged.


I bought this specific item (and the M40 mouse) as a treat for undergoing an invasive medical procedure and all it's changed my mind totally about Corsair products. being in my 30's I can say that I've used plenty of PC hardware over the years and never had any trouble installing drivers or getting basic functionality to work for any of them.

Link to comment
Share on other sites

Another thing; when speaking with the man from technical support, I mentioned the driver being called 'Corsair Gaming Batman Keyboard' to which he said 'What?'.


Can someone from Corsair explain the Batman part? That's the driver straight from your website.



Link to comment
Share on other sites

  • 1 month later...

I'm having the exact same problems with my new M95 mouse as "Tonemapped" when i boot up my computer and im at the login screen to enter password (win 8.1 64bit) everything works perfect.

After filling out my password and windows starts loading the driver for the mouse my whole USB interface freaks out, all my USB devices including keyboard and the mouse start blinking and i keep hearing an USB connect and disconnect sound, things keep blinking like a light show.


When i boot up without the M95 in any port everything is ok, after that when i connect the mouse its a 50/50% chance things work or will start blink again.

I have tried diffrent USB ports (USB 2.0-3.0) but makes no diffrence.


I dont feel like its a hardware problem but a driver thing. plz help out Corsair.

Link to comment
Share on other sites

found a work around, installed the drivers on my laptop and configured the mouse there and save to mouse memory. then plug it in my main pc without any of the corsair drivers and im good to go. no light shows no crashes and everything works fine.
Link to comment
Share on other sites

  • 11 months later...

Hola a todos,


me siento muy desconcertado porque desde el 27 de junio de este año hasta la fecha no me he sentido comodo con este problema de los productos corsair con windows 8.1, ya que tengo el mismo problema con ese teclado raptor k50, sin embargo me toco formatear mi pc de windows 8.1 a windows 7..


por favor estoy atento a sus comentarios......

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...