Jump to content
Corsair Community

Force F80 not compatible with Haswell?


Recommended Posts

I updated the motherboard in one of my computers to a Haswell/Intel 8-series socket 1150 board.


Trying to install a fresh copy of windows onto the Force F80 (CSSD-F80GBP2 on latest fw 2.4) that I already had in the PC I got lots of problems with the disk, the problems were already at bios level. Sometimes the disk was visible, sometimes it disappeared in the bios. Sometimes windows saw it but refused to install on it, refused to format it or didn't see it at all. Or happily installed and then randomly would boot or not. Totally random. After trying all settings you can imagine in the bios without seeing any improvement, trying new sata cables, all different sata ports (both Sata II and III) another PSU, removing any addon cards, trying other memory sticks and so on.... and finally I ended up thinking the motherboard was faulty. But just to make sure I tested the disk again with the older motherboard, no problems at all and another older PC. NO problems there either.


So I quickly went out and bought another board, same chipset (Intel B85) but this time a Gigabyte mobo instead of the first which was an Asus.


To my surprise I got the exact same random problems with the new board! The disk comes and goes randomly. Windows can sometimes install and boot once or twice but then says there is no disk, try a boot again and it might work. And already in the bios it randomly comes and goes.


So.... I took another disk and installed windows. Without a hitch. Straight sail through.




At this point I started to wonder why the combo Force F80 and Intel B85 was shaky. The F80 works great with all other mobos I've tried it on. And the two B85 boards work great with all other disk I tried.


So I googled a bit and found that another SSD-manufacturer has a problem with one of their SSD-models and haswell/Intel 8-series chipset boards. They have gone official saying they have a problem with this model and 8-series chipsets and that they currently have no solution to the problem.


I haven't (yet) found anything about F80 disks and Haswell/8-series when googling though.




Any thoughts?



Should I submit a support ticket maybe?

Link to comment
Share on other sites

There are no compatibility issues.



What controller does the F80 have?



The first gen Sandforce seems to have a problem with Haswell (confirmed by both mobo and SSD manufacturers).






Raja @ ASUS wrote:

You are correct that SSD is not supported. I'd recommend using another drive.



MarshallR @ ASUS wrote:

SF1200 based SSDs are unsupported on 8 series chipsets unfortunately. I think the more recent SF2xxx series are fine, but someone will have to confirm.



me&er wrote

I am sorry to say that afaik at this moment in time, SSD with the SandForce 12xx/15xx series controller are not fully compatible with any Haswell platform.



Praz wrote

Hi. At this time SSDs using the SATA 3Gb/s SandForce controller are not fully compatible with the Haswell platform. .... There is currently no workaround to correct this.


Robert wrote

Right now it is unknown whether a workaround or solution will come from either the motherboard side or the SSD firmware side, if at all. As we have more information we will post that information here on the forum.





Link to comment
Share on other sites

There are no compatibility issues.


I've googled a bit more and found a lot of people having problems with the exact combination of Sandforce 1200 based SSD with Intel 8-series / Haswell chipsets. And it seems the whole Corsair F-series (F80 / F160 and so on) is based on Sandforce 1200?


Is Corsair working on a firmware update for the F-series SSDs with a fix? And when can we expect it released? I'm in a really frustrating spot right now with my computer not possible to run at all with it... Really unhappy about this "surprise" :(::sigh!:

Link to comment
Share on other sites

  • 2 weeks later...

No comments?


Only way to get the F80 to work with the haswell motherboards is to buy a separate PCI-express SATA card based on some other/older sata chip and connect the F80 via that instead.... :mad: But then it's stable :sigh!:


IF there is some way to make the F80 work directly with the haswell chipset motherboards please post.

Link to comment
Share on other sites

Hi MagnusT


same Problem here.


Ich have an old Corsair F60 with FW 2.0 (the upgrade to 2.4 doesn't work) and just upgraded from an B75 to a H81 based MoBo.

With the B75 MoBo the F60 worked fine, with the H81 no chance. Doesn't matter if a SATA2 oder SATA3 port is used.

Fortunately I had an old PCI-E SATA3 Card with Marvell Chip, with that the F60 works fine again.


Please, Corsair, work with Sandforce and make a firmware that fix this problem.

Link to comment
Share on other sites

@Corsair Support Team


It's now almost a month, since MagnusT pointed out clearly the problem between Sandforce SATA2 controllers and Intel 8-Series Chipset, and I can confirm that fully.

Is there any chance, Sandforce will develop a Firmware update for this problem, or are those SATA2 controllers that old that nobody cares?


Please answer.

I don't know, if I should order a new SSD or wait.

Link to comment
Share on other sites

the whole original Force series has been discontinued so I would not count on any f/w update. I would buy a new SATA3 drive and it will suit most needs in the near future.

SATA2 is pretty much dead as far as any drive manufacturer is concerned, their money is on the prize winning bull SATA3 (for now until SATA4 is developed.)

Link to comment
Share on other sites

  • 1 month later...

The same case with my F160, 3 year old without any problem on Intel 755 socket as boot SSD,

with new ASUS Sabertooth Z87, include SATA ports on additional ASMedia controller.

Is anywhere any answers, news, fix or workarround for this problem?

Open Ticket for Corsair support 6233632

ASUS CASEID=RTM20131107200371-647

Link to comment
Share on other sites

As resume of private discuss:

- Nobody care 3 years old hardware support.

- No hope to fix this issue. Workarround 4 this SSD is use external SATA card / use AMD platform or old Intel.

- LSI/SandForce, Intel and SATA standartization (it's like a woodo magic).


For me - no any LSI equipment in my enviroment (sorry Corsair, u use bad in long term parthnership platform), to go buy Samsung 840 pro.


here is little bit more technical describes and potentianal existing fix:


but nobody care :(

Link to comment
Share on other sites

  • 3 weeks later...

I'm having the same issue as the OP. A working Corsair F120 is intermittently recognized by the BIOS in a new Haswell PC. I'm using the most updated BIOS. I tried to update the SSD firmware from 2.0 to 2.4 but the update didn't work in two different PCs, using two separate tools. The SSD is currently in the 2nd year of the 3-year manufacturer warranty.


Motherboard: Gigabyte GA-H87-D3H

CPU: Intel i5-4670

SSD: Corsair F120 (Firmware 2.0)


This problem has been documented:

We have seen some older SATA 2 devices that are out of spec (8-series has tighter tolerances to specs as platform power is much lower – but fully complies with all SATA specs) and have intermittent behavior, we are investigating whether this particular drive [Corsair F120] is one of those.


Obviously Intel is aware of a "problem" internally, although the fault may not be on its end.


Doing a bit of digging we found that some 1200 and 1600 series SandForce controllers are not fully SATA specification compliant and the previous Intel chipsets allowed for this out of spec behavior. It seems that the Z87 will not allow for this as it requires "strict adherence to the SATA specification." We did test the workaround BIOS that ASUS sent us without issues using the older F120 SSDs that employ the Sandforce 1200 controller. So obviously, this will have to be solved at a motherboard BIOS level and something to keep in mind if you have older SATA 2 SSD drives. This issue does not seem to be "widespread" though as Intel sent us a chart that contains many SATA 2 drives that have been verified to work fine with Z87 chipsets.



Since this appears to be a known compatibility issue between the SF-1200 controller and Haswell chipsets (and the fault is on Sandforce / Corsair's end for not being within SATA spec), I expect one of the following:

(1) A workaround to get this drive to work reliably in the new PC (we've tried disabling various power saving options in the BIOS and Windows 8.1)

(2) A refund

(3) A replacement unit from a newer series with a different controller (e.g., a Corsair Force 3 series unit, which I also own)


I just submitted a ticket (ticket number: 6289838). As this problem has been known for nearly 6 months and has not yet been addressed, I fully expect (2) or (3) at this point, especially considering how much time I've spent researching to pinpoint this problem.

Link to comment
Share on other sites

Corsair has stood behind their product and agreed to RMA the F120, promising to exchange the drive for one powered by a Sandforce SF-2000 series controller. Those with Haswell-based PCs experiencing issues with Corsair drives not being recognized in the BIOS should consider an RMA (assuming the product remains within the 3-year manufacturer warranty). I'd recommend updating your BIOS and SSD firmware first to see if this solves your issue, since at least one motherboard vendor (ASUS) has released a BIOS fix that compensates for the faulty Sandforce SF-1000 series controller.
Link to comment
Share on other sites

  • 4 months later...

Hello guys,


I have also bought a corsair f80 two years ago, and now it is not working anymore in my new pc. Gigabyte Z87M-D3H with a Core i5 4670. Latest F9 bios is installed, but no luck. if I am lucky, I can access it in one out of 20 tries.


will also go for rma, as it is still in the 3 years warranty range.




Link to comment
Share on other sites

  • 4 months later...
  • 5 months later...

Don't mean to bring up a dead topic but...


I am having these same issues with a few F60's.


Had 2 running in raid0 on an Nehalem setup (i7 920 - Asus Sabertooth X58) without issues. Then on a Ivy Bridge setup (i7 3770k - Intel Extreme DZ77GAL-70K) without any issues.


Now that I am running a Haswell setup I cannot use them.


Current motherboard is an Asus Sabertooth Z87 and when I use the Intel Z87 sata controller or the ASMedia sata controller when I power on the machine the F60's are , most of the time, not detected. The firmware on the SSD's are the most recent version 2.4. The bios on the motherboard is current, although I have also flashed the first bios version before any revisions were made to see if I could get them to work. When connected using a USB to sata adapter there were no issues. My system is able to see the SSD's through the boot process every time. Also, I am still running both previous setups I mentioned and the F60's continue having no issues with both of those machines.


I don't expect this issue to be resolved, just thought I would share my recent experience

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...