Jump to content
Corsair Community

H100i suddenly not connected


Recommended Posts

Hello people!


I have a 'serious' problem with my H100i fan, and that is the fact that it wont get recognized by the link software nor by the BIOS. Side note: I'm not even close to be a pc expert, so I might've missed it in the BIOS but I'm positive that it's not to be found in the Corsair Link 2 software.


The funny thing is that it has not always been this way. I have been able to control everything about my H100i up untill recently (including changing color/fan speed/profiles). The ANNOYING thing is that the fan is CONSTANTLY running at max speed, so it's LOUD as ****! I can't use this PC with sleeping people near me, as it would wake them up.


I have NO idea what caused this problem, and have tried everything my mind could imagine would help. When I try to update the firmware (to H100i_v_1.0.5) I get this error:

"Status: H80i/H100i not connected!".


I've tried reinstalling the Link software, but it did nothing good.


I've tried installing Windows 7, but it did nothing good.



Please help me... I'm completely lost. (Sorry if this is already answered/solved, but I've honestly been searching for fixes about 1 month now and have found nothing that helped - I might just be blind!)




Gigabyte Z77X-UD3H



Intel Core i5-3570K CPU @ 3.40GHz


Memory (part number)

8.00GB Dual-Channel DDR3 @ 807MHz (9-9-9-24)


Video Card

MSI R7970 Lightning BE


CPU Cooler Corsair H100i 77.0 CFM Liquid


Hard Drive # 1



Hard Drive # 2



Optical Drive




Vengeance® C70 Mid-Tower Gaming Case


Power Supply

Antec 620W ATX12V / EPS12V



S23A750D (1920x1080@120Hz)


Operating System

Windows 8 Pro 64bit





I will take a couple of screenshots & pics of my setup.


CorsairLINK 2 software (Main Screen/System):



CorsairLINK 2 software (Groups):



CorsairLINK 2 software (Graph):



CorsairLINK 2 software (Options - General. Note: Ticking "Show all devices" does not help anything):



CorsairLINK 2 software (Options - Devices):



CorsairLINK 2 software (Options - Logging):



CorsairLINK 2 software (Options - About):




(Pics of the insides of my PC will come soon)

Link to comment
Share on other sites

your cooler isnt showing up in your link software

many things can cause this,such as

having installed a update that is interfering

a usb port conflicting with another installed device

you can check your connections,try another usb port,look to see if there was a update installed prior to this occurring,even installing software can sometimes affect things

Link to comment
Share on other sites

  • 3 weeks later...

Thanks for your responses! Sadly, none of the mentioned solutions worked.


Here's a couple of pics of the inside of my PC:











(I've named the cables, so that you know where I put each one of them.)





BTW: I've tried both windows 7 64bit, windows 8 64bit & windows 8.1 64bit. It didn't work in any of them. I found fan speed in my bios, but it didn't change anything. I've tried a couple of different fan speed programs but they didn't work either.

Link to comment
Share on other sites

Did you tried to connect the fan connector on your H100i at the other connector at the side.

Could be that your fan controller is dying on the H100i.

Try to connect the faulty fan to your mobo; can you change the speed of the fan in the bios; if yes; then your fan controller of your H100i could be faulty.

Try to uninstal link; power pc down; disconnect usb cable from h100i; reboot; install link; reboot; shutdown pc, connect usb from h100i to mainboard; boot pc and look if it shows up in link.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...