Jump to content
Corsair Community

K70 Vengeance and the num, caps and scroll-lock under Linux

Il Corsaro Nero

Recommended Posts

Three days ago, I purchased the K70 Vengeance black with Italian layout and cherry MX red switch (CH-9000011-IT).


Spectacular! I like it very much!


First: I want the possibility to buy (easy way: I want to buy them in Italy, in my shop, in my city) the contoured keycaps for the arrow keys.


Second: I have read many posts about problems on the Linux operating system and unfortunately I was not able to solve them all.

The lights for scroll, num and caps key are not working properly in Linux: the three lights are always off (in 1,2,4,8 mode). The keys NUM, CAPS and SCROLL pressed many times but nothing, they are not lighted.


They work perfectly under Windows 7 64.


This is my situation for your feedback:

- Main Board Asus Rampage II Extreme with the latest bios

- No UEFI bios

- The lights works flawless in Asus bios of main board

- Linux Kubuntu 13.04 64 bit

- Tried a different USB port

- Tried Kernel 3.8.0-25 and 3.8.0-27

- Shutting off completely the PC many times

- This happening regardless of polling rate: 1,2,4 or 8

- Only in bios mode, the lights for NUM and CAPS works, but the SCROLL flashing continuously (and do not responds to key pressed)


If I use the command:


sudo kbd_mode -u


I see that changes the keyboard to 16bit utf8 mode.

After this command, the lights for num-lock and scroll-lock works, but not the caps-lock. Also this happening regardless of polling rate: 1,2,4 or 8

I add the command to my startup programs.


If I change my xorg.conf to include:


Option "AutoAddDevices" "OFF"


in the ServerLayout Section, the keyboard stops working completely.


Have you any ideas?


Best Regards.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...