Jump to content
Corsair Community

H100i FW 1.0.7 and SW 2.4.4948 LED Glitch?


Recommended Posts



I came across a thread where it states that the 1.0.7 firmware fixes the detection issue with the Commander. So I ran the 1.0.7 firmware for the H100i (Connected via USB header on MB) using SW 2.4.4948 and it got stuck at "Verifying Bootloader".


So I closed the window checked the FW version and it said my H100i was 1.0.7.


But here is my problem, my H100i is working (pump, LEDs and fans) with the USB header cable, it also works and detects everything when connected directly to the Commander. But when I shutdown and bootup the LED is white and then it changes itself to a pinkish colour.


I then have to launch the Software take all the sliders up to "reset" the LED colours. I have checked to see if it can display all possible colours and it does without any problem and all colours are bright.


I just want to know if its a software glitch?


I have the Lighting Node, Cooling Node, AX860i and H100i all connected to the Commander.


Any helpful response will be appreciated.


EDIT:My brother has almost an identical setup and he also updated his H100i yesterday and his is doing the same thing except his turns to a light blue because he previously had it set to Blue and mine turns light pink/red as I previously had it set to red. Really weird.


I tried the link SW 2.2.0 version to see if it was the latest software but its not it still does the same thing. Im going to try the previous 2.3.4816 and try changing the port on the commander.


Unless there is a way to completely reset everything "link" related? I have got a feeling that its the 1.0.7 firmware for the H100i.


EDIT: I tried a different port on the commander and SW 2.3.4816 and it still does the same thing.


So from my conclusion its the 1.0.7 Firmware for the H100i that is interfering with the LED. Is anyone else experiencing the same thing????


Any help please?

Link to comment
Share on other sites

  • Corsair Employees
Did you have the H100i cooler connected to the Link commander? If so then so then please use the USB Cable and connect it directly to a MB internal USB port and try flashing the firmware again as noted in the Firmware update post for F/WE 1.07.
Link to comment
Share on other sites

Okay I tried exactly what you asked and still the same thing, in the software when I set the colour to a solid green, blue, red or any colour and I shutdown and bootup the colour would change to a "lighter colour" of whatever colour I set it to....


Everything works and gets detected pump, fans, led but when I set the h100i led to a colour I want, it always makes that colour lighter on a shutdown and startup....


I then have to reset the colour in the software, its getting really annoying....

Link to comment
Share on other sites

Okay I reverted back to fw 1.0.5 and leds on h100i are working normally when I set the colour in the software and then shutdown and reboot it stays that same colour. The only thing now is that I cant connect it to the commander and have to use up another usb header :-(


So it has to be the 1.0.7 firmware that is messing with the leds on the h100i.

Link to comment
Share on other sites

  • 1 month later...

I have the link and cooling kit with the H100i


Just updated the Link software to the 2.4.5110 then proceeded to updated the h100i firmware to 1.0.7 from 1.0.5.


Firmware app crashed while waiting for the h100i to report back... SEE IMAGE of screen shot




I sent the report and it closed the app. Fans on the rad span down then back up again.


looked back into the link software and the H100i LED had gone. Relaunching or rebooting made no difference.


What i did have was the USB and link cable connected to the cooling block at the time i did the firmware update. after shutting down the system i removed the USB keeping the link cable connected and rebooted the system.


H100i LED came back up in the system list.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...