Jump to content
Corsair Community

Corsair K90 driver issues under Win 8 64


Recommended Posts

First post here, so hiya all! :)



Got a minor issue with my K90 ever since I switched to a new system and Win 8 64 about a week ago.


As I did on my old systen, I (re-)flashed the K90 with the latest firmware (1.36), then installed the driver ( 061113.exe). Did all this with the "Run as administrator"-command, BTW.


And right after that, the keyboard functions normally. Software runs in the background, comes up on click and works to program macros. Additional buttons and the volume knob also work fine.


However: Once I restart / shut down and start again, the additional functions (most importantly mute-button and volume control) no longer work. Everything else seems ok.. LEDs are on and can be dimmed and the keyboard itself functions of course (typing on it right now :) ).


I can temporarily fix this by uninstalling the driver and re-installing it, but that fix will only last until the next re-boot.


I've also noticed that the K90 doesn't *really* show up in the relevant HW-sections of Win8 (device-manager/control-panel's "keyboard"-section). All I see here under "keyboards is 3x "HID-Keyboard" and my Razer Taipan mouse. When I go into the keyboard-section properties and click on the "hardware"-tab, I'm (again) getting 3x HID-keyboard. The first two are listed as generic standard-keyboards. The second to last on that list has these properties:

Manufacturer: (standard keyboard)

Location: corsair gaming keyboard

Status: Device working properly (or something like that, re-translating here, since I'm working on a German version of Win8).


Shouldn't Win recognize the K90? And why do I keep losing the additional functions and is there a way to fix this?


Oh, BTW: The K90 is connected via two USB 3.0 sockets, directly on the MB.


Thanks for your help.




Link to comment
Share on other sites

Thanks for the heads-up, I *think* that this might be the cause of my problem, since I can't seem to find the HID-Service in the list.


I looked up possible translations on the web for the German version, but none of those I could find were on the list.


So, naturally, I can't start the service. How do I add it to the list?



Already checked my System32-folder and the dll that's supposedly needed for the service (hidserv.dll) is indeed in there.


Update: I found a "how to" on MS' support site and checked my registry-entries. They were all set to "20" (as they should) and were pointing to the correct dll using the correct path. I still can't find the service in the list though, but I did find it in the task manager's "services"-tab, where it was listed as "stopped". When I start it in there, the controls work again. But upon system-restart it's set to "stopped" again and I have to do a manual restart.


I'm guessing that as long as I don't enable it permanently in the administrative tools\services list, it'll just get deactivated again upon reboot. But how do I do that when it's not even listed?




Update to the update: Finally found it. MS, in all their wisdom, chose a pretty obscure translation for the service, at least when you're working your way back from the English name. Unlike in the task-manager, there's no mention of "HID" in the title they chose for the services-list (why even have two different names for the same thing?), *and* they don't mention this translation on their German how-to support-page (guess it's translated by software, not a human being). Well, now they do, since I changed their translation via the "improve"-function they have on there.


So I simply enabled the service manually in the task manager, then checked all active services in the service-list. If anyone on a German system has similar trouble, the service is called "Zugriff auf Eingabegeräte". Set it to "automatic" and now everything works as it should.








Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...