Jump to content
Corsair Community

Reinstalled Corsair link, now no Fans or LED


Recommended Posts

I recently reinstalled my corsair link system in my system after updating it with a DIY watercooled system. I previously had been using an H80, but upgraded to a custom solution.


Before this move I had the Corsair link installed in my system and it worked fine. It monitored all my temps and I could easily control my case fans using the fan module, as well as my LED's supplied with the lighting module. During the course of my rebuild, I removed the guts of my system and installed it into a test bench and only connected the main Corsair link module to monitor temps and didn't install the fan, or lighting modules. I used the system for about three months like this....


Fast forward to this weekend, and when I finally got everything installed and working in my new rig I am unable to get the fans or LED module to be detected in the corsair link software.


I know they are getting power correctly since they all (the fans and LEDs) power on when connected through their respective modules, but they are not identified or controllable inside Corsair link software. I have checked and rechecked the connections between the modules and the main corsair link unit and nothing changes. I have even uninstalled and reinstalled several different versions of Corsair link software, going back to the original Version 1. I am currently running 2.3.4816.


My system components are below and I am running Windows 7 Ultimate. Any direction is appreciated.


Motherboard: Asus Z77 Sabertooth

CPU: Intel I7-2600k

Ram: Corsair Dominator Pro 1600 (16GB)

PSU: Corsair AX 1200


HDD: OCZ Vertex 4 SSD

Case Fan: (x3) Silverstone 180mm fans

Case Fan: (x2) Silverstone 120mm fans

Link to comment
Share on other sites

Same fans worked in the previous install. So am not sure if that is it. The only thing that change was the addition of a rad, pump and related watering cool parts, but none are running through the Link. Link is connected to same fans, same led's that worked previously. Is possible I connected something wrong, but am hoping for some assistance from forum that might lead me to solution.
Link to comment
Share on other sites

I will try some different USB headers.. but this is a new motherboard and scenario is after a complete reinstall of the OS and all apps. Components are more or less same, but I did change MB. Am unaware of any specific issues or conflicts with Link and my board.
Link to comment
Share on other sites

  • Corsair Employees


I just caught something, you had been using an H80 previously and not an H80I correct? If yes then how did you see the H80 in Corsair Link do you have our Corsair Link and Lighting Kit? What exactly do you have and what is it connected to IE Fans and Coolers connected to Corsair Link?

Link to comment
Share on other sites

Yes, I had been using the H80, not newer H80i.... I do have both the lighting and fan modules currently as well.


Previously, I was able to see the H80 as another device and could control its fan speeds, etc. separately. (it had its own cable going to the C-Link (far right hand side connector I believe). The new configuration doesn't use this connection b/c I am using a third-party water block.


The only thinks that are connected in this new configuration are;


Corsair Link to MB via USB header, Fan module to C-Link via Slot 1, Lighting Module 1 to C-link via slot 2, then a second lighting module to I think slot 3 or 4 on C-link.


As it is connected, I have five fans all running through fan module and then five LED strips (corsair supplied) running through two lighting modules. All four units, C-link, Fan and two lighting modules have their own power connections to the AX1200, which is again the older style without the 'i' designation or C-link connection.


Hope this helps clarify.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...