Jump to content
Corsair Community

Ax860i Power Efficiency via Corsair link


Recommended Posts

Hi All,

I just purchased an AX860i PSU. Popped it in my rig, opened corsair link, clicked on the power tab only to find that the PSU I have is delivering:


73% efficiency on idle,

79 - 82% @ 50%,

87-89% on 100% load.


Isn't this PSU supposed to deliver 90+


Should I RMA this? Or am I missing something?


Link to comment
Share on other sites

Thanks for the reply, much appreciated.


I do note the info provided on the link, however, per reference he says below 150w Link is not accurate. Well I was drawing over 150w and the min should be 82% not 73%. I just want what I paid for a really efficient PSU I had an AX850 and upgraded it to this.


On my work PC with the same AX860i PSU it rarely goes below 91%. So should I return?

Link to comment
Share on other sites

  • 4 months later...



I recently had to RMA my previous AX860i and I have received the new AX860i PSU and installed it without any problems. However if I use the Corsair Link software the power efficiency is acting very strange. It fluctuates every interval (1s) from values around 65% to 45% and sometimes even 25%, in idle. With my previous AX860i PSU I had no such problem because the efficiency was almost always above 85% even in Idle. Then I tried to put it in load by playing high demanding video games like battlefield 4 and then it stabilised around 75%. This is still low compared to my previous AX860i and considering the graph on http://www.corsair.com/us/power-supply-units/ax-series-power-supply-units/ax860i-digital-atx-power-supply-860-watt-80-plus-platinum-certified-fully-modular-psu.html it shouldn't even go below 90%. I know this is theoretical but 65% and drops to 25% is extremely low. Note that I did not install any other version of Corsair link nor did I uninstall Corsair link after I shipped my previous AX860i. It is the same corsair link version 2.4.5110. Also I use the same USB header for the Corsair Link USB Dongle. Any kind of help would be welcome, thanks.


RMA ticket number: #6315566

Link to comment
Share on other sites

The link software is very buggy my 12v atx and 12v peripheral in logging says it dropped to 3.3v while playing battlefield 4 if this had been the case I think my system would of crashed. As with the efficiency mine seems better now that I have it pluged in to my h100i


Yeah I've read a few posts saying about the buggy link software, but you must know I find it hard to believe since I had no problems with the same software version on my previous AX860i.


Anyway I would like to know how did you manage to plug the AX860i into the H100i? I tried it before but it didn't seem to get it in properly. I'll post a picture below. In the left goes the digital link cable of the H100i and I tried to put the comm link cable of the AX860i into the right but it doesn't seem to fit properly. Or is there another port on the H100i I need to use for the AX860i?




Link to comment
Share on other sites

I plugged it into my H100i and suddenly the power efficiency doesn't drop below 75% anymore, so weird. But then again other values such as Main Voltage is around 207V while there is an input of 220V. So yeah guess it's all in my head and the program itself is faulty.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...