Jump to content
Corsair Community

PSU Coil Whine / RMA issues (again!)


PepprmintNtmare

Recommended Posts

I previously had a TX750 V2, which RMA'd due to fan problems a few months ago. (The fan was always at 100%, so produced a lot of noise...) The PSU I received back was a V1, which I was initially annoyed about but hey ho, it's pretty much the same thing right?

 

Now this V1 has coil whine, which cannot be fixed by changing power settings, bios settings, etc... It kicks in all the time, even just when I'm just browsing the internet or word processing, also when the GPU is at high load. The previous V2 had none of this!

 

I'm pretty annoyed, seeing as I payed £25 or so to have the last one replaced due to excessive noise, and got another one with a similiar problem! Also I don't think I should have to go without a computer while I wait for an RMA again!

 

Ideally Corsair would advance ship me a new PSU (V2, like I bought initially, if possible) since this is the second time. I don't want to pay for shipping from UK to Holland just to have this same problem again.

Link to comment
Share on other sites

I'm pretty annoyed, seeing as I payed £25 or so to have the last one replaced due to excessive noise, and got another one with a similiar problem! Also I don't think I should have to go without a computer while I wait for an RMA again!

In your case it would be best to call CS when they open.

 

Just explain to them what has happened and that you would like it replaced again. Be sure to ask for a shipping label too. They will cover shipping charges both ways for you on second RMA's.

 

You would also be able to ask about an advanced replacement at the same time. You would need to call them anyway to arrange this because of CC security reasons.

 

Using SKYPE or any other VOIP application from a smart phone or PC makes it a free call from just about anywhere in the world.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...