Jump to content
Corsair Community

M30 Gaming Mouse Stopped Working


Recommended Posts

I bought an M30 gaming mouse about 12 hours ago and the USB connection at the front of the mouse has basically crapped out. It worked fine when I messed with it this morning. I played Left 4 Dead to test out the DPI and the thing kept disconnecting. So I plugged it into another port and it kept happening. I messed with moving the mouse and it would disconnect if I moved down and to the left. It progressively got worse as I tried to use it to find a solution. Now it doesn't even work just sitting straight and I've plugged in another mouse.


I made a quick video of what is going on.


Is this a common thing with Corsair mouses or gaming mouses in general? I've been using basically a decade old Microsoft optical mouse and thought today would be the day I upgrade after testing out my friend's Razer Mamba.


I guess I need to contact Fry's electronics and see what it will take to replace it/return it. I just want to know if you guys have had any experience with this mouse in particular and if I should even try getting another one.

Link to comment
Share on other sites

No its not a common issue. It looks like there is an issue with the USB wire.


If Fry's does not replace it for you. You can request an RMA to replace it.


All right. Thank you. I wanted to make sure I got a second opinion regarding the USB cable on these mice because I really like the feel of the mouse, and the rubber grip, but was disappointed when it started disconnecting.


I called Fry's and the guy told me they should have them in stock and that I could drive down and get a replacement. So I guess that's what I'm doing now. Haha.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...