Jump to content
Corsair Community

H80i no hardware detection and no led lights


Recommended Posts

Well, I plugged all cables, fans, usb, power, and turn on the computer and not look at any time no light, starts the OS, but does not detect any hardware change, I open the device manager and I see listed the H80i, force a detection hardware changes and does not detect anything new.

I tested this with both the provided USB cable, plugged directly into motherboard as a regular USB cable, plugged into an external usb, with the same result.

I've never gotten him ever detected nor seen any LED on.

After that, I installed the software Corsair Link 2 rc-v2_4_4948 but not detected at all any H80i and logically does not report its firmware version.

If I try to update the FW manually, it reports that it doesn't detects any H80i.

What can I do?

Link to comment
Share on other sites

I've been looking at the specs of the USB ports on the motherboard manual, and all of them (6 external and 2 internal) are USB 2.0.

Anyway, given your notice, I tried plugging in all of them, with the same result, nothing at all.

Link to comment
Share on other sites

No LEDs, never.

I had to connect the fans directly to the MB because if I connect them to H80i them makes a loud and annoying noise.

A few months ago, shortly after buying the H80i, I requested an RMA to change the supplied fans because they were noisy.

I was sent a new pair with 4-pin connector. It is supposed i've to update the firmware to be able to use them, which I can not do.

If I plug them to the H80i still makes a lot of noise, which is very annoying if for some time.

So I decided to plug into the motherboard, and the noise disappeared.

After that I've been with health problems, and I couldn't devote myself to solve this problem before.

May be i've to request an RMA for the whole H80i?


(Many thanks for your answers, and sorry my poor english, i'm using a mixture of 'googlematic' translator and school memories)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...