Jump to content
Corsair Community

K95 G keys not working with some MMORPGs!!!!


Recommended Posts

Since November 2012, I had been delighted to learn that Corsair is finally upgrading the hybrid-mechanical K90 to a Full-Mechanical K95 and had been anxiously waiting for it to hit the market.

On May 30, 2013, K95 finally arrived and I'm pretty sure that I am one of the first few who actually went and bought one home.


It was a very well built keyboard I must say. It's backlighting has to be one of the best I've ever seen. Very sweet keyboard.


Then, my nightmare began.


The reason why I bought this keyboard was for an MMORPG I played for a long time called Final Fantasy XI (FF11).


I spent hours programming all the G-keys to various in-game functionalities and tested them all on a simple Text document and all the macros came out well.

I even accidentally clicked a G-key while I was in MS-Excel and the commands I programmed shows up as Text in Excel.


When I launched FFXI, none of the G-keys responded at all while I was in game.

When I bring a Notepad document, to the foreground, the G-key will function. However, when I am in-game, the 104 keys on the keyboard would function as I can still move around and chat with people. But none of the G-keys worked.


I even tried all the different BIOS switch settings and that didn't help either.


I unwillingly returned the product to the shop today (14-days return deadline) and now I'm posting here, with the hopes that someone can provide a solution to my agony and I will gladly re-purchase the keyboard again.


I'm running Windows 8 64-bit.


Any help is greatly appreciated because I really love the keyboard and wants to own it again!!



Link to comment
Share on other sites

You can't test these unless you have the keyboard with you but here are my suggestions.

- Enable hardware playback.

- Put small delays between the keys. Sometimes macros that try to execute as fast as possible are cut into bits by the rate a game registers keys. For example, I had on my old G15v2 (so not a problem with this board) a command that I press in Company of Heroes 2 which went: enter (to enable chat box) -> letters ("there is no need to be upset"). (It is a line I need quite a lot). Without delays, the chat box sometimes opened but mostly just assigned my units whatever commands were assigned to the hotkeys of the letters I wanted to type. Putting a .1 second delay in some spots fixed it. Maybe your macros are incremental in that if the first command doesn't register the rest won't (e.g. pressing E only has an effect after pressing C), making it look like nothing has happened.

Link to comment
Share on other sites

Hi cakes,


Thanks for your reply!!

Unfortunately, I've tried both methods you've mentioned (prior to returning the keyboard).

1) Hardware playback

I don't really know what that hardware playback checkbox is so I've tried with it both checked and unchecked. Both scenario it worked on Notepad but not in game.

2) Small Delays

Because the default automatically insert a 50ms delay, some of my macros contained those delays and yet, it's still like pressing a blank key and nothing shows up in game. Yet again, it works fine on Notepad.


My macros are simple one liner. For instance:



/ma cure <me>



In fact, I've even started a chat line in game by typing some random characters like :





Then I pressed the G key, hoping to see:



skjfhsdjkfdshkfsdfh/ma cure <me>


But nothing at all. It is as if the G key has not been assigned.


I do have other brands of game keyboards (actually, it's the same keyboard that you've mentioned) and it works like a charm. I just hate using rubber dome and that's why I switched.

Link to comment
Share on other sites

I actually haven't found out how to do this yet but I think the software can have different profiles for different programs. Maybe somehow it already knows how to recognise the game and switches to a profile you haven't programmed. Or simply the M1/2/3 buttons changed. Apart from that idea which is pretty far-fetched, I don't know to else to suggest. Good luck in finding a solution.


Edit: There could be a round-about solution in a macro simply activating a AutoHotkey process, if that program works in-game where the Corsair software doesn't.

Link to comment
Share on other sites

Before enabling hardware playback, you will have to save your profile to the K95 before it will work in-game.


It should be found in the "manage profiles" section or something similar



even though when the G keys are working fine in Notepad and Excel?


Thanks for your reply too, Toasted!

Link to comment
Share on other sites

Yes, a lot of games block software playback usually online games as it may bring an unfair advantage over another.


When you save the profile to the K95 it will store it on the K95's onboard memory. When pressed, it will act like a normal keyboard inputting keys to the computer.

Link to comment
Share on other sites

Thanks Toasted. I will go and repurchase the K95 and give it another go (and I have another 14 days to try it out again).

Having said that, I own another 18 macro keys keyboard (as mentioned above) which DO have onboard memory and I own a 15-key gamepad (previous Belkin, now owned by a different company that I shouldn't mention in the forum) which DO NOT have onboard memory and both of them work fine in the game though.

Link to comment
Share on other sites

YAY!!!!! Resolved!!

Toasted is right! (Given his posting quantity, I shouldn't have doubted!)

I went and repurchased another K-95.

Found the "Save To K95" key under the "Manage Profiles" Tab.

After pressing the button, there will be a progress % next to it allowing users to see whether the Save is completed.

Then Check the "Hardware Playback" checkbox and click "Close".

Start Game, and everything works fine!!

YAY! This keyboard is a keeper!!

Link to comment
Share on other sites

I have similar problem but with my mouse M95. I could not even type in notepad when I change my M6 button to keystroke Number 6 for example. Could anyone give me the reference on changing my Macro maybe i got it wrong somehow :(
Link to comment
Share on other sites

  • Corsair Employees
I have similar problem but with my mouse M95. I could not even type in notepad when I change my M6 button to keystroke Number 6 for example. Could anyone give me the reference on changing my Macro maybe i got it wrong somehow :(


How are you setting it up? Click the i button in the software and copy paste to me what it says. Then make sure you don't have hardware playback checked until you're done setting them up.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...