Jump to content
Corsair Community

Sudden huge write speed Drop Force GT120

Recommended Posts

he folks,


in the morning ssd was working fine, since one hour everything is like in time lapse.

Did few full benches with ATTO, everytime same result.

the screenshot is from a canceled bench , cause it's exactly the same, just to show you how messed up.

Did chkdsk .. cleared cache..


- ssd is about 1 1/2 years old

- 42% free space


other info in attachments.








thanks for all in advance !








Link to comment
Share on other sites

What does "like in time lapse" mean?

What do you mean you cleaned the cache? Do you have a third-party Ram-Cache Application running?


Your read seem TOO HIGH, so what you are benching is probably not your drive but a bad piece of software laying in the ram.


ATTO is not designed to bench ram-cache, neither is this corsair able to "help you" as long as this software is running. Refer to the software-rendor or try read the manual (in case of fancy-cache: everything is very well documented). I guess you should ask the makers of that cache-software why it shows slowdows on certain chunk size.


Why did you cancelled ATTO? Please run the full benchmark.


When i run fancy-cache with deferr write enabled all values show up nicely until it reaches a certain chunk size of at least 128, but when i stop it and restart from 128 these values are fine too, the reason a continuus big bench shows slow downs is because you just write big bunches of data and the cache-software on some point has to flush the data to disk... at leats in case it is full. the moment it tries to flush gigabytes of bench-junk-data to the disk then slows down. when it not flushes to disk because it detected the data got deleted and simply delete it from ram then in that moment still the ram needs to process that deletion. That doesnt mean that your real performance now end up slower than without cache... it simply doesnt mean ATTO isn't designed to measure ram-caching. Try ASSSD!


What is your Sata-Mode in BIOS?


To restore performance you can try sending TRIM-command via the Toolbox, but i fear TRIM beeing disfunction in your FW-version was a bug.


You have old Firmware, try to update via Corsair Field Updater/Sand-Force Flash Utility, youll find it from the sticky thread regarding your drive's FW in the archive-updates in the FW-Update section.


P.S.:Nice writes within 18 Month. That 120GB drive wrote approximately 8700 Gigabytes of data, thats 72-times the capacity, so probably some sections of the drive may had 100 write cycles.... but dont worry, should be of no harm yet :):

Link to comment
Share on other sites

thanks for the fast reply.


timelaps just means, when i open chrome it normally pops like in the moment i hit the button, now i have to wait 10 secs to have igoogle-startpage fully loaded.


and no, no ram software, just cleared all Temp files with ccleaner and boost speed.





Sata mode is AHCI


But how come i need to update my firmware. i didn't change anything.

System was rock stable till today.


well i i need to make a partition backup before firmware update , do i ?


no way without cloning ?


Thx for all info,




Link to comment
Share on other sites

The speeds really look weird. Most of the read speed are faster than the drive physically is capable of, thats why i assumed a ram-cache-software.


Are you sure that your motherboard SATA-Controller driver is properly installed?


Certain bugs only may appear in certain situation. Maybe you encounter such situation now.


Hard to say what exactly is causing the anti-rocksolid-thing you encounter in the FW, since there is no real detailed changelog available. New driver may changes the way it handles the drive and so it could still address very old problems.


Dude, i can't answer "how comes, everything was fine, didn't changed anything?" ... there are bugs in firmware. there are newer firmwares that fix bugs, so when it's no more stable you should come to the idea "update FW".


Especially when there was 1.3.3 that adressed serious bugs, 2.x and now even FW-series 5.0x.


Normally a firmware update does NOT force you to re-install at all and does NOT force you to make a backup, just do it, even as Boot-Drive, but there's no warranty the FW-update-process will work at all, it may brick your drive, and maybe all data will be gone, so you have to backup your own data in your own interest.


From person to person: Developers tell users not to apply FW-updates in general and recommend it only when things go wrong because they think people are high likely not able to properly do it (read the manual) and/or against acknowledging any blinking messages that "the process is at high risk" still forgetting to backup their data and then claiming it'S the resellers fault.


I did every single FW-Update for my Force 3 as a Boot-Drive succesfully without losing data.


Backing up your data isnt neccessary but recommended.

Attaching Drive as storage is not neccessary, but recommended.

Unplugging all other BUS-devices and setting up AHCI in BIOS is not neccessary, but recommended.

Removing OC or attaching UPC isnt neccessary, but recommended.


Theres no sense in backing up your hole drive with imaging. You should try to back up your personal data (the game-save-folder in the windows-user-folder, programms, images, etc.), then on a fresh install copy-back your specified windows user-subfolder. You sould minimize backing up system-data because of the corruptions.


When finally have a fresh installed customized system that is a state you say is final, then you should do the extra work to start backup with imaging.


Good luck.

Link to comment
Share on other sites

What is "boost speed"?


OK i got it it's a proprietyly heavily system affecting "cleaner" from auslogistics, that might think enabling prefetch is a good idea for SSD or maybe you decided to... :D:


In "boost speed" on "tweak manager" > system > prefetch, what is enabled?

Should be all disabled.


Whats your windows-service Superfetch state?

Should be disabled.


Whats your windows-service Defrag state?

Should be disabled or manually, but not scheduled on C:\

Link to comment
Share on other sites

In boost speed,

All prefetch option are d, but isabled.

Only thing was was enabled was the windows supercache.

Defrag is also disabled, i use auslogic, but unly for my data discs.


Perhaps the ssd is out of life, and i should send it in.

Thx again for all your time and energy...



Link to comment
Share on other sites

Great to see your drive managed to show up 5.05, very very good :D:


I cannot find the supercache in boost speed. You mean windows-service superfetch? Good, the SSD is fast enough, the prefetch/superfetch thing is meant to squeeze the last bit out of HDDs and comes at high CPU/RAM-cost, on the other hand most of these measure dont affect the SSDs performance.


Which SATA-Controller and -port is it plugged in?


Please please make sure that the Sata-Mode in BIOS really is AHCI and not raid. I know you already replyied to that, i just repeat for a double-check!


Check the alignment (see ASSSD)


Do an ASSSD Benchmark and post that screenshot.


YOu can check the drive in windows-device-manager. I would not like to start a flame-war, but in my opinion, i recommend you, to disable write-cache for the SSD... you may check with benches if enables gives you a benefit on the other hand.


ATTO must be wrong regarding your results. It's impossible to achieve +3GB/s read without RAM on a single disk. but even for RAM your small-chunk reads are too pretty damn high... as I at this moment... hehe... no consumer-pc is that fast, so it's probably fake data.



P.S: I fear the drive is fine and your controller is sending fubar :D: try the disk on another PC first before you send it... just to make sure!

Link to comment
Share on other sites

[ Corsair Force GT ATA Device ]



Gerätebeschreibung Corsair Force GT ATA Device

Treiberdatum 21.06.2006

Treiberversion 6.1.7600.16385

Treiberanbieter Microsoft

INF-Datei disk.inf


SSD physikalische Information:

Hersteller Corsair

SSD Familie Force GT

Bauform (Form Factor) 2.5"

Controller Typ SandForce SF-2281VB1

Flash Speicher Typ Micron 25nm MLC NAND

Gesamtgewicht 80 g

Max. sequentielle Lesegeschwindigkeit 555 MB/s

Schnittstelle SATA-III

Interface Datenrate 600 MB/s

Puffergröße 0


well i disabled write caching on the device and did a bench with asssd.

sata mode is definitely AHCI




well, seems the controller is sending fubar, but system is noticeable slower.


i am going to see if i got the bill somewhere. in 3 weeks i am abroad, gonna send it back if its still in warranty time. :damnit:


Thx dude.


Link to comment
Share on other sites

First the ASSSD look quite more normal than the previous ATTO, from what i see in ASSSD your drive fairly operates fast.


The alignment is ok, the driver is MSAHCI, thats the default microsoft driver, not the Chipset-one.

Are you sure that your motherboard SATA-Controller driver is properly installed?

i reinstalled sata driver.

Sry, no, not from what i see.


Info of the drive in device manager is irrelevant, you have to check the sata-controller in device-manager and you have to install your motherboard vendors SATA-Controller-driver to achieve full performance.


PS: TRIM may not work since the data on your drive was written with a FW that had broken TRIM... i guess it will work once you wiped the disk and started from scratch.


PPS: So dass muss jetzt mal auf deutsch raus. Das soll hier nicht vorwurfsvoll klingen. Das "Treiberangebot" von Intel auf deren Homepage ist das unübersichtlichste was ich je gesehen habe. Du ziehst dir 4-5 fulminant klingende Riesen-Treiber-INF-Packs und dann musste doch die hälfte noch weitersuchen und nachinstallieren. DU schaffst das :) aber hey ich glaube nicht das die platte im eimer ist. Da würde ich eher noch an der voll verendeten Status (ups ich meine natürlich VOLLendeten, haha)von Win8 denken.

Link to comment
Share on other sites

Oh it is 7.

ensure you are logged in as administrator-account, click Start > Run > Type: cmd, enter:


fsutil behavior query DisableDeleteNotify


return 0 means TRIM-sending-by-OS is ENABLED.

return 1 means TRIM-sending-by-OS is DISABLED.


should return 0.

if it returns 1, then enter:


fsutil behavior set DisableDeleteNotify 0


what enables it. then try sending TRIM via Toolbox again.

Link to comment
Share on other sites

but i keep it in english, just for others :biggrin:




i guess now it's the right driver. but its not really faster.


i have installed Win7 x64 SP1,


speeds were before 510/520 or something like that , but both values above 500.


You think a performance restore per HDerase would be a good thing ?


Danke !!


Link to comment
Share on other sites

ASSSD should show something like "iastor" not "MSAHCI", so in case you want to achieve full performance, once again, please make sure you installed your motherboard-vendors SATA-Controller driver properly. In doubt ask Asus or Intel. Im out of that with an AMD.


I dont know about hderase. There is a sticky thread about how to restore performance with WIPE-Command. Check the forum, please.

Link to comment
Share on other sites

Yup leave it there. Anway, sometimes it is higher sometimes it is lower, FW permanently processes things in the background, so does your OS or running programs do. Even the Windows-System-Loggs on 7 cause lots of writes. Rerunning benchmarks might decrease because the FW might hadn't processed TRIM between and the benches writing lots.


You should not be attracted to benchmarks and it is completely unrealistic to achieve any of the advertised speeds in real-life. They measure massively bursting chunks of ultra-compressible data. In real-life you dont read or write 32 times 8 Megabytes of Zeros (256MB) and call that measurement "sequential R/W".


To measure the fastest 8Mbyte transfer when constantly stressing the controller with Zeros, is not the same then really sequentially read or write a real piece of big continguous data... not even close.


Das ist leider Pustekuchen! Oder anders gesagt völlig übertriebene Mondwerte. Und ganz ehrlich das hat nur einen Ziel: Mehr Verkauf! Was auch sonst, ist normal, ist bei den andern SandForce-verkäufern auch nicht anders üblich. Eigentlich übertrumpfen die sich bloß noch regelmäßig selbst mit ihren Ammenmärchen. SSDs die weitestgehend auch das einhalten was draufsteht gibt es von Samsung oder von Intel... erstaunlicherweise steht da weniger drauf und die sind doch teurer. Und jeder ders hinterher erfährt könnt sich in den Hintern beißen dafür auf diese Masche reingefallen zu sein. Ich auch! Aber die müssen ja alle selber zusehen wie sie dieses Image (Schwindler) wieder loswerden wollen. Meiner Meinung nach reicht es nicht einfach zu behaupten "also Schwindel kann man das nicht nennen, ist doch formell alles korrekt.", denn der maßgebliche Punkt ist das Kunden mutwillig über die zu erwartende Leistung getäuscht wurden aus Marketing-Gründen...man kann ja nciht erwarten das potentielle Käufer VOR Kauf die Software ATTO studieren... Intel und Samsung tun das nicht, verzichten also darauf auf dem Papier rumzulügen und die Produkte vermarkten sich quasi wie von selbst! Ich werd mir jedenfalls keine SandForce mehr kaufen auch wenn die neueren Generationen besser sind. Vereimern lass ich mich max einmal. :D:


The "time lapses" or i guess you mean timeouts/freezes can be caused by applications or system-functions, like HDD-drive suspend, pagefile on HDD etc. If you still encounter general system-wide freezes with that speeds-level now you should start backing up your data and prepare for a fault soon... since the speeds are good.


There's another problem next to limited write-cycles of the chips... and it's called electro-migration, i guess that is next big reason what is causing chips especially the chips-controller-parts death next to faulty-PSUs.

Link to comment
Share on other sites

well, thanks for the help :roll:


just figured it out on myself, just to let you know..


i dont know why, but it was the sata cable that came with the board...

i switched to the second 6Gb cable and suddenly it worked on the intel controller too, from what i can tell from the benchmark


performance should be ok.. ?




this post was from october 2011


with the same win7 x64 i run today, same components and drivers, till yesterday when i started to update drivers cause system was SUDDENLY EXTREM SLOW


the speed values (both above 500) was not from was written on the box, it was from my first bench with ATTO.


as i said performance drop was from one minute to the other




sidebyside with same components i can tell there is something ****t up.





Link to comment
Share on other sites

You are a little wrong. The ATTO benchmark is only reference in your drives specification for r/w-seq-speed. According to that ATTO benchmark your drive is capable of writing 595 MB/s (see 8192) and capable of ultra realistic 4,175 GB/s (see 4096) no matter it look different than your old measurement.


According to ASSSD your drive operates all over at acceptable/good performance and have acceptable response. Your expectations are wrong. Live with it!


Still have havent reported to test the drive on another system with ATTO again to make sure your system isnt buggy accessing the drive for whatever reason. Thats important to stop everyone looking in ther glassbowl without you sending it in.


Otherwise I stll still likely assume you have one of the following products installed and/or actively running while testing ATTO:


Primo Ramdisk

Dataram RAMDisk



SuperSpeed RamDisk

O&O CleverCache

Qsoft RAMDrive Enterprise


Gilisoft RAMDisk

SoftPerfect RAM Disk



Thats why i stop here now. Shut the cache-software down or if really none existing check the drive on another PC or request RMA.


To prove you that you can have wonderful speeds with "odd-looking" ATTO results i show you this.




No system-hickups/freezes here.


Link to comment
Share on other sites

wow, how come you get these results with asssd with your drive ?


well, can't thank you enough.

you spent a lot of time here with me ;)


ill try to test the ssd on a friend system this weekend.


i let you know whats the result.


Thx alot,


and good night !





Link to comment
Share on other sites

  • 2 months later...


This topic is now archived and is closed to further replies.

  • Create New...