Jump to content
Corsair Community

Vengeance 1500 won't be detected anymore


StareX

Recommended Posts

Hello Corsair!

 

I have the Corsair Vengeance 1500 for a long time now. Please let me mention that this headset wasn't bought by me, but by my mom.. and she doesn't have the receipt anymore .. so I hope it won't affect my warranty. I have the Corsair Vengeance 1500 for 5 months, and bought it from a retail store named IVORY. I really love this headset and the sound is superb on them! I enjoy it so much!!

 

Now, today I have ran into a little issue. My headset, all of the sudden stopped working and I was very frastruated. How did it happen?

 

Well, basically.. my cable management was like this:

http://i1342.photobucket.com/albums/o780/HyperZpeed/5EA05DE05D505E005D404_zps6cdb1d9b.jpg

 

Well basically, the cable was around this big cone at the end of the desk .. the cone next to the wall, do you see it? that is where the cable was and all the way to the right was the cable .. pretty good managed and didn't disturb anything.

 

Now the thing is, when I woke up at this morning, I wanted to check out what is up with the PS4 Press Conference.. I really wanted to watch it but noticed my volume was at 20 precent.. now I wanted to kick it up right?.. but the volume didn't work on the vengeance volume box.. I tried pressing on them but it didn't work.. why? because the keyboard has a + and a - volume too.. this:

http://i1342.photobucket.com/albums/o780/HyperZpeed/5EA05DE05D505E005D406_zps2ba4745d.jpg

 

So I pulled my PC like so:

http://i1342.photobucket.com/albums/o780/HyperZpeed/5EA05DE05D505E005D405_zps87882e79.jpg

 

and put my hand towards the back, and unplugged the Keyboard USB ... tried so hard till I succeed.. I pulled my PC alittle bit more cuz I couldn't reach and made it.., I unplugged it and returned it to the USB again.. (plugged it) .. and the volume worked.. but the headset wasn't.. I was shocked, and then when I saw my PC Screen at the left side.. I saw a message poping up.. I didn't pay attention to it.. but I know it said "Windows has disabled a USB device and it got removed" or something... when I looked at my headset volume box, I saw it's not lighting anymore, no sound.. no mic....

I have looked at the cable, pulled my PC once again .. like I did last time, and tried to reach to my headset cable.. but I didn't manage to.. I pulled it back in and moved my DESK to reach to the back side of the PC.. so then I saw the Vengeance cable disconnected...

I wanted to connect it back in but then I noticed the cable was under the cone.. the last cone I showed you above next to the wall.. the cable was UNDER it.. so I moved it out from it and managed to plug the USB back into its original place.. looked back into my PC screen and then to my headset, but no luck.

 

 

What have I tried to fix this issue?

I have tried to reinstall the USB Drivers, didn't work.

I have tried to look at my USB Cable, found NO damage at all.. no damage to the USB connection either..

I have tried to connect the headset into another PC and it didn't work.. (2 PCs to be precise)

I dunno what to do..

 

 

P.S. I have found an interesting thing, you know the cable is connected to the volume box .. right? so I put my thumb and two fingers onto it and start to feel that the braid cable is moving, I tried moving it till to the end of the box and the braid cable got fat...

http://i1342.photobucket.com/albums/o780/HyperZpeed/5EA05DE05D505E005D403_zps0484f178.jpg

No damage on the USB either:

http://i1342.photobucket.com/albums/o780/HyperZpeed/5EA05DE05D505E005D402_zps507ad1ab.jpg

 

I dunno... then I moved it back to its original place and kept on watching it.. I tried moving the other part .. around 8-9cm away from the moving braiding and it didn't move.. only below 8-9cm when it touches the box moved.. So weird.

The cable .. when it was under the cone next to the wall, was pretty tight.. so I moved it away to free it.. :/....

 

How this whole processing of the RMA goes? I mean is there any other solution that can avoid RMA? I don't know.. this is the only headset that was available on this retail store.. it's like this headset is being discontinued on my country.. only the vengeance 1100 or 1300 appears on the retail store.. what.. why? :(

WHAT CAN I DO? PLEASE HELP! :(((

Link to comment
Share on other sites

  • Corsair Employees
If you've tested the headset on different machines and it doesn't detect it, put in a RMA and we can help you replace it. Don't worry about your retailers not having it as we don't use their inventory for RMA.
Link to comment
Share on other sites

If you've tested the headset on different machines and it doesn't detect it, put in a RMA and we can help you replace it. Don't worry about your retailers not having it as we don't use their inventory for RMA.

 

So right now I should wait for an RMA confirmation? Please let me know how it goes.. I just put the box in another box and send it to you through Postal Mail? will it cost me money to send it and you replace it? or it is free for replacing and/or sending ... ? I am new to this and I have NEVER done this, neither my family..

Link to comment
Share on other sites

  • Corsair Employees
What is your case number? And yes, you would send it to us at your expense through any courier you choose (just get a tracking number in case it gets lost) and we will ship you a replacement headset after we receive and process it.
Link to comment
Share on other sites

Solved.. I got a replaced Corsair Vengeance 1500.. and to be honest, they're more comfortable, more sound.. and better sits on my head without even tweaking the "tight" cups.. what the heck? :D.. it's better than the last headset. SO STRANGE!!!!
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...