Jump to content
Corsair Community

H100i :: Corsair logo flashes blue during boot


Recommended Posts



H100i with LINK software 2.2.0 installed.


During boot the logo on the pump flashes blue then stays off - then CPU Fan error.


Fans on the radiator still have power, not sure if the pump is running - too many fans adding vibration to feel for flow. Temps seem normal (haven't risked stressing it)


I can skip the CPU fan error and load into windows just fine (have disabled the cpu fan monitor in bios for now). LINK software shows the pump stats at 0 and fan rpm at 0, but the fans are running.


Things I have tried



Rolling back the firmware but the bootloader says "h80i/h100i not connected" and fails.


Hot plugging the USB header (no LED)


Switching the USB header (no LED)


Hot plugging SATA (fans die then come back on, no LED)


Reseating the CPU Fan header (no LED)



I am down for any suggestions, seems like I'm one of a few people with this issue - but unlike the rest, my fans are still running.


Problem started after my desktop sat for a few days without being powered on. I noticed an issue when I received the "CPU Fan error" during boot.

Link to comment
Share on other sites

The tach wire looks fine. Removed, inspected, replaced - no LED.


One element I didn't mention earlier was, I was able to resolve the issue twice by flipping the power switch at the PSU (Corsair HX1000W) and booting back up. That doesn't work anymore though.


I am 100% certain the SATA power has plenty of juice too.

Link to comment
Share on other sites

i never had any good results using the 2.2.0,seemed there was too many bugs for me including ghost icons and icon failures.you can try a uninstall and use the Corsair Link 2.3.4816 which has the 2.0.6 .that works great for me

of course this doesnt address why it worked and then stopped

you can plug a fan into the cpu-fan to remove that error and see what happens once booted but your right,this problem hasnt come up here that i recall.

Link to comment
Share on other sites

I rebooted with a case fan plugged into the CPU FAN header, and the tach wire on an OPT fan header. Booted as normal, but the h100i still has no LED and the LINK software still says everything related to the h100i is at 0 - yet my fans are still running (powered off the pump) and as far as I can tell, the pump is running - radiator feels warm as normal.


I'll try uninstalling the LINK software and use a different version. My guess at this point is the installation will complain that the h100i is not connected.


Will report back.

Link to comment
Share on other sites

ill be here if i can be of help

Thank you, sir!


Uninstalled 2.2.0, cleaned all remaining traces.


Installed 2.3.4816 with zero errors during installation.


Rebooted with no LED - LINK software reports no h100i components.


BUT.. I can now see my three 6970s instead of only one, suppose thats an improvement.

Link to comment
Share on other sites

try one more thing,pull any external connected usb devices and do a cold boot,some m/b's are finicky with the link.id stay with 2.0.6 i think its better

also are the link icons showing but with 0 readings?

if so if you can show a pic of your link devices in expanded device view.

Link to comment
Share on other sites

I pulled all the usb devices, even mouse and kb - cold booted with a blue flicker, then no LED. Rest is the same.


I couldn't locate 2.0.6 for anything other than the commander, is there one for the h100i?




You can see the pump and fans are missing from the devices. Prior to reinstalling LINK, they were listed - but as 0 on stats.

Link to comment
Share on other sites

ok,you have no link at all showing so your working only on the software as it shows no hardware connected.

you can try moving the hydro to another usb header and try that,and if you have a usb/mini usb cable you can also try hooking it to a rear usb port,in fact i have all 3 of mine hooked this way as i found it most stable


if after trying these 2 checks and still no success,you will have to be looking at a bad hydro controller.[which is most likely the problem]

Link to comment
Share on other sites

I had tried another header previously with no luck, but the micro usb cable to an external port.. brilliant!


Sadly, nothing changed. A blue flicker then no LED.


It seems like it is simply corrupted - is there a way to reset the firmware somehow?

Link to comment
Share on other sites

flashing wont help,it isnt detecting the hydro

honestly it has to be a bad hydro

i know you dont want to hear this.

ramguy has mentioned in the past of pulling and connecting the usb while its running to sorta shock detection but after having no luck with everything else,i doubt this will help you.

you can recheck here tomorrow,others may be able to help

Link to comment
Share on other sites

Okay. Well, a bad hydro makes sense to me as it detects power and then fails to continue operating.


The pump is still running, and the fans are still spinning - but programing ramps and using profiles via LINK is now worthless.


Looking like an RMA :[pouts:


Thank you for your help, good sir.

Link to comment
Share on other sites

well,you are persistent i must say,you do know you can request an advanced rma where you get the new unit first,then send the old one back

this requires a c.c. and you need to call to set this up.

I am telling you guys it is a conflict between corsair link and AI suite..Mine stopped detecting my CPU temps and i get MB temp is -.85c or such all the time.There are plenty of others that have this conflict..Look it up..
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...