Jump to content
Corsair Community

Very Frustrating RMA problem. Help Please! :(

Recommended Posts

Hello Everyone,


I was advised to write here by another thread I made about this.


I raised an RMA request 5-6 weeks ago. It has still not been answered/approved (RMA no: 6015910)


After about the 2nd or 3rd week I also emailed corsair with the email given on their webpage, with the same question I'm asking here. Again, still no reply.


Am I raising the RMA ticket in the correct place? I have the feeling I'm doing something wrong.


Can someone please advise me on where to raise the RMA?


I was also told on another forum it them 5 weeks for a reply. Is this normal? I'm getting quite worried that I'm running round in circles not getting anywhere.


Any advise/solution would be greatly appreciate as I'm getting very frustrated.


Link to comment
Share on other sites

  • Administrators

6015910 was automatically approved when you created the ticket. You should have received further email instructions minutes after creating the ticket.


I just created 6034532 for you. Please check your email.


It certainly does not take 5 weeks to get a reply. Whomever told you that is incorrect.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...