Jump to content
Corsair Community

Refurbished F180 issues with Windows 7

Recommended Posts

I'm putting together a low budget system and I've run into a problem that has me utterly stumped.


I picked up a refurbished Corsair Force F180 SSD, installed it in my system, no problems - it appears to be properly detected in the bios and is set to AHCI. I pop in my windows 7 home premium CD and start installing windows. All is going well, until the computer needed to restart to finish the install.


Well, the computer did the restarting just fine, but it took an unusually long time to get back to the windows installation. Once it finally got back to it, I was prompted to enter a name for the computer. I hit a key on my keyboard and nothing happened... Odd. Thankfully my mouse was responding, so I clicked the accessibility button in the lower left corner with the intention of bring up the on-screen keyboard... and nothing happened. I decided to just wait and see if it was going to do anything at all, and about 5 minutes later the accessibility options finally came up. I don't know how else to put it, but there was some ridiculous response time going on for everything but the mouse. I tried installing Windows 7 Ultimate (different CD) and had the same problem.


I managed to get an install of windows 7 on the SSD and booted the computer up for its first time visit to the desktop. After about 30 minutes (roughly 10 of which were spent staring at the word "welcome") I ran out of patience and just shut the computer down, as I was pretty irritated by how unbelievably slow things were going.


I was about to give up on the computer for the night when I decided to go ahead and try an install of Ubuntu 12.04 on the drive, thinking that if it is outrageously slow as well then the drive must be defective. Unfortunately (for my sanity) the install went quickly, the computer restarted, and booted Ubuntu in seconds. Everything was responsive, programs opened quickly, everything was snappy as it should be, and I was at a complete loss as to why the computer was struggling to run windows 7 but had no problems with Ubuntu.


I then put the SSD in a different computer (2nd gen i5, Z77 chipset) and it didn't have any issues when installing windows 7...


Then I took a regular hard drive that had windows 7 installed from a different computer, put it in my computer, and it booted up perfectly fine! What in the world is going on???


F180 + windows 7 + My PC = Bad

F180 + Ubuntu + My PC = Good

F180 + windows 7 + Other PC = Good

HDD + windows 7 + my PC = Good


I'm at a loss with this computer... Any help would be greatly appreciated, thanks!

Link to comment
Share on other sites

Latest BIOS?

Have you tried installing the chipset drivers during the install?

Have you tried a different SATA port and cable?

Bios yes, Drivers no, SATA port yes, cable no


Have you tried disabling Power-Suspend features in your BIOS like C1E etc.?



My suggestion would be to check the firmware of the drive to see if it has the latest firmware revision. If not then use the SSD Toolbox to update the firmware.

Sounds like a good next step.


Since Windows is having the issue it would take me all day just to install the SSD Toolbox. Anyway that I could update the firmware in Ubuntu?



EDIT: I took Toasted's advice and switched sata cables and installed a sata controller during the windows 7 install, and things went buttery smooth after that. I'm thinking the sata controller was the issue. Thanks for the help guys!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...