Jump to content
Corsair Community

Link 2.3 & 2.4 Beta not starting under Win8/64Bit


Recommended Posts



i have the following problem:


I bought an H100i a few months ago and everything worked fine till my system was upgraded to a Windows 8 Installation.


after installing the 2.3 Update ( Beta from a Month ago ) the Corsair Link software worked on the System flawless.


Yesterday, i wanted to correct the fan speeds of the watercooler, and i saw that the Ilink software did not start anymore.


I completly purged the installation from the disk ( clean uninstall followed by manual Profile delete in appdata/roaming ) and reinstalled the 2.3 Release from today.


Same Problem: When i click on the link for the App, the system seems to start it for around 5 Seconds ( no splashscreen / program window , just that activity mouse cursor thing ) and then nothing starts, in the task Manager there is also no sign of Corsair Link Running.


I tryed this reinstall ( with several Restarts everytime ) a few times also with Version 2.4 but no start seems to work.


Any clues, how to fix this?

Link to comment
Share on other sites

Nope nothing,


Neither the Win 7 or older compatibility mode are working.


Since the Corsair Link installed itself as Admin only Startable Executable its necessary to give it the rights upon all starts, but i tryed it also with rightclick start as Administrator.


Its still the same problem, system seems to work for 3 -6 seconds, no screen apears, no process is started.

Link to comment
Share on other sites

The only two versions with Win 8 Support are the old 2.3 beta / final ( same Build, so i think they are identical , however i tryed the BETA and the Final of this Version ) and the 2.4 Beta.


Older versions do not work under windows 8 at all.


So yes same problem with the normal and the actual beta version.

Link to comment
Share on other sites

  • Corsair Employees
I would suggest Corsair Link 2.4.4948 and even if its installed now go to options then devices and remove any profile you have set and set to defaults and then exit and wait a few min then close the software and uninstall it and uninstall the Corsair USB controller driver. Then reboot the system and when you install it right click on the install or setup program and run at an administrator. The set it to start at windows start up and see if it starts on your next reboot.
Link to comment
Share on other sites

Yeah this way will not work, since the Programm itself does not start.


Neither the Hardware Monitor or the manual startable program.


I removed under c:\users\username\appdata\roaming\ the corsair link configuration & Profiles manually after a uninstall over the Programs & Functions from Windows 8 itself. Then did a restart, fresh install of the actual 2.4 Beta and restartet again. still no luck, to get the window up again.

And yes its installed as Administrator.

Link to comment
Share on other sites

Yeah but i really don't know what is causing this,


I already set up my notebook with Corsair Link and connected it via an standard USB Cable to my H100i, this works fine to set the settings.


but i cannot find an issue with the Win8 PC, since everything else works fine.


Are there any special dependencies for Corsair Link that must be met , any dlls or Visual Studio Redist files or a special Version of .net that is necessary or eventually an special Java / Flash version?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...