Jump to content
Corsair Community

Corsair Vengeance 1500 Not being reconised


Recommended Posts

Hi, I have a Corsair Vengeance 1500. It worked fine for awhile but not it wont even think it's there. When I plug it in to my comp it says, "Device not found."

When I try to install the drivers it says, "Please plug in your Corsair Vengeance 1500 headset." When I go into sounds/device manager it says "Unknown Device" with a triangle. Can anyone help me? I will not EVER do a RMA unless necessary. It worked on my moms computer. Just not mine. Any help?


I use Nvidia cards with a custom built computer. The headphones used to work fine.


Please help. :mad: :evil::wtfman:

Link to comment
Share on other sites

Is the Hardware Ids

USB\VID_1B1C&PID_0A01&MI_00 and USB\VID_1B1C&PID_0A03&MI_00


Device manager>Right click the device>properties>details>hardware ids


If so, Extract the V1500 installer then try manually install the drivers via Device Manager.


Right click>Update Driver software>Browse.....>Browse to the extracted folder>Next



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...