Jump to content
Corsair Community

AX1200i self test succesful but can't power on?


Recommended Posts

Hello, today I received an AX1200i via RMA, before installing it I tried the self-test, it powered on, the fan started spinning, and the LED turned on.


After I installed it in my PC and when plugging the power cord in and flipping the switch on the back of the PSU to On (I) my motherboard LED isn't turning on (so I can't I boot the computer either).


When holding down the Self-Test button while still hooked up to my PC it will turn on the leds from the PSU, my motherboard, graphic cards and also all case fans start spinning (case fans aren't hooked up to a fancontroller only directly to the PSU, so GPU and CPU fans are not spinning). While still holding down the Self-Test button I tried to boot my pc using the power button of my case, but this doesn't work either.



Nevermind solved, it was a stupid human error (a cable from the PSU came loose)

Link to comment
Share on other sites

Yeah thats one of the quarrels I have the AX1200i, its really hard to confirm if a cable is properly seated inside the PSU, im so used to hearing a quick "snap" but instead it feels like pushing a penny into silly puddy.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...