Jump to content
Corsair Community

First No PSU in Corsairlink Now no H100i


Recommended Posts

I have had this system built for about 25-30 days. And tonight, I notices the fans were louder. I open Corsairlink and had no listing for my AX1200i PSU had to do a reboot for a SSD firmware update. I am running 2.3.4816 and have firmware 1.05. The H100i had been working until I rebooted. I have tried removing Corsair and Sierra from the registry after uninstalling it. When I re-install Corsairlink it starts with the firmware upgrade screen. I have tried flashing the 1.05 upgrade but it says file error. SO I can't get into Corsairlink at all now. Also I have a yellow triangle in my device manager, it says Unknown USB Device(Link in Compliance Mode). Also all the fans are now running at 100%. Here is a screenshot from right before H100i disappeared. Now I can't even get into the software. It had been working very well, I had 5 different profiles(IE Gaming, Quiet, Movie, Video Editing, and 3-D CADD)


Any clues on what happen to my system?

I really hope it can be fixed without any rma, I just went thru an 16 day rma on the Mobo...




Link to comment
Share on other sites

Submit an RMA for your PSu and request to have the LINK dongle replaced.


Just use the link on the left to request an RMA


Once you recieve your RMA number you can call CS buy phone and request an advanced replacement. That way it will only take a couple of days to get the part you need.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...