Jump to content
Corsair Community

Not happy with Toolbox


Recommended Posts

I have two Neutron GTX's in RAID 0. Knowing that Toolbox doesn't work with RAID, I backed up my system, and then deleted the RAID array. After that I set the Neutrons to AHCI mode, and installed Windows on one of them just for the FW update. Got everything up and running, installed Toolbox, and it recognized both drives straight away, and also found the latest FW to upgrade to. So I initiated the first FW update, and got a "Firmware update failed" notification, after which I got a blue screen, and a bricked drive........just that easy.


So, thank goodness I have a spare mechanical drive, I am now installing Windows yet again on this mechanical drive, and have my fingers crossed that Secure Erase will bring back my bricked drive, and then I'll give Toolbox one more go with the two Neutrons being completely wiped clean by Secure Erase, so there should be no reason for the FW update to fail........I hope.


I'll post back and let you guys know what happened, but as of right now, I wouldn't recommend that ANYBODY use Toolbox to do a FW update without backing up their system first, and also without having a spare drive to use just in case it bricks your main drive(s) without warning.

Link to comment
Share on other sites

Okay, Toolbox has officially killed a drive. After a whole bunch of trial and error, I got one of the two drives to accept the firmware update, and it seems to be working fine. The first one, on the other hand, is still dead, and not only will it not work, but it's keeping my system from booting at all. I ended up installing a spare mechanical drive complete with a clean install of Windows, and when I have the bricked drive connected to the system, Windows won't boot on the mechanical drive. I have chosen the proper boot drive in the BIOS, and done everything possible to get the system to boot to the mechanical drive, and as long as this particular Neutron GTX is connected to the system in any kind of capacity, it kills the whole thing. Just to make sure my settings are all correct, I reinstalled the Neutron drive that properly accepted the FW update, and Windows boots up just fine from the mechanical drive. There are only issues when the bad drive is connected.


All I can say here guys and gals, is I have learned to leave well enough alone. Toolbox has really done a number on my expensive drives.

Link to comment
Share on other sites

1. Have you had only one drive connected on Sata0 during the update, or were both of the same drive connected? Why not unplugged the other to make sure the system has only one single flashable drive left? That might me problematic because flasher pics right FW from signature.


2. Which SATA driver was installed at the time during the FW-update? I hop MSAHCI, not any other proprietary.


3. What was the version of the FW before the update? Update from 1.3.x to 5.xx via Toolbox is actually not supported.



Have you tried unplugging the defective drive from power connector for at least 30 seconds?


If it wont work you can request RMA, i guess it's not that old.

Link to comment
Share on other sites

1. Initially, I had both drives connected since one of them was running the OS, and could not be removed. It wasn't until the first failed attempt, which instantly bricked the drive, that I had to remove one of the Neutrons to make room for the mechanical drive. Once I had the OS running off the mechanical drive I updated the FW to each of the Neutrons with only one connected at a time.


2. SATA driver was the latest Intel driver.


3. Prior to updating the FW was M206, and after the update, it was M208.


4. Yes, I tried unplugging and swapping and anything else I could think of but can't get them to work now......well, one of them.


I have decided to just do an RMA. At $250 (price I paid) per drive, I'm not going to take any more chances than I already have. This is starting to be a total nightmare, never again.

Link to comment
Share on other sites

1. never have more than one drive of the same type connected during FW-update, as i already said, the flash-utility determines the right version from the drives signature, it may go confused by two times the same drive present with different signature and might took the wrong one for the wrong drive.


2. flashing with your motherboard chipset vendors proprietary driver is not supported, may fail without progress or just may brick your drive. always switch to MSAHCI for max compatibility and sefety. the reason is that - in your case - Intel changes drivers algorythms on and on, they maintain changes to increase performance or to increase stability or widen the featureset of that driver, but what they do not do is to ensure their driver works with any SSDs FW-update out there. The MSAHCI-driver instead is a static set of algorythms, that are prooved to work (basically because MS doesnt apply performance or stability improvements as long as they are avoidable, because they so busy with security-fixing, but thats another story). Any SSD-manufacturer tests their FW-updated based on that MSAHCI driver.


From my point of view, trying to update of two of the same SSD at the very same (run-)time with accessing them through the Intel-Driver framework is totally risky! Im sry to say thats, but its just my personal opinion.


3. i guess thats the one that succesfully applied FW-update, after the first one got "shot down".


4. the pronountion lays on, "at least 30 secs without power", swapping the drive from one pc to another with just few seconds power-loss is not enough! that'S because of condensators that still spend power for a short time after power-cord-unplug. It is important to give it some time without any connection for it internally to reset! this probably will NOT HELP in case the FW really is fragged.


in general: FW-update failures can always happen, no matter which tool you take, departe from power-outages. if another mechanical drive fails during the SSD update, that usally screws up the hole (sata-)bus, if just for example a CD in a optical-disc-drive in that moment has a read-error, that will screw up the FW-update process.


To minimize chances of a fail:

1. ALWAYS unplug all other drive-devices (SDD,HDD,CD,DVD,etc.), especially drives of the same model, except the single one you want to update. Repeat for the others.

2. ONLY use MSAHCI driver in windows and ensure BIOS is setup to AHCI.

3. Close any application might using the disk, especially RAID utilities, RAM-disks.


I doubt that in your special case this would have prevent the brick, but to blame anyone is not alright IMHO. I can understand that you are angry about it and want to blame someone, probably the only one to blame for would be "corsair". At least you have 1 primary SSD left to install an OS and getalong until the other one gonna be replayed, so c'mon, image what it would feel like if that was your only disk, and then, please feel a bit lucky ;)


A wise man once told me "shi* can happen", that's basically what you accepted when downloading and executing FW-Updates. Im praying to my knees everytime ;)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...