Jump to content
Corsair Community

Cannot update firmware on Force 3 120Gb


Recommended Posts

I cannot update firmware on Force 3 120Gb (1.3.3)...


I have an I7 3770K and a Asus Sabertooth Z77


Already tried on win8 and 7...

I am using AHCI.


tried with AHCI standard windows driver and with intel drivers.


I did a new windows instalation in another harddrive and installed only network driver so I could download the firmware.


Already deleted any SSD partitions.


Already changed the cable and controller ports.


I always get the message: "Firmware update failed."


Any ideas?

Link to comment
Share on other sites



1. get older firmware (5.03) and the sandforce update utility from here, precisely check you download the right capacity version.

Corsair SandForce 5.03 Firmware Update - All Drives and Capacities HERE, SATA3 ONLY


2. ensure you use MSAHCI and BIOS-Sata-Mode AHCI and close any third party tools and programs (famously Raid utilities and RAM-drives, virtual drive managers like daemon tools), if unsure choose a clean boot.




3. Update FW with the sandforce update utility to 5.03, on success... give it some minutes!


4. Proceed with 5.05 as usual (toolbox) or with the sandforce update utility, whatever you like.




PS: Ensure you choose first Sata-Connector of main Sata-6gbps controller and if unsure unplug all other devices.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...