Jump to content
Corsair Community

M90 moving on its own after firmware upgrade


Recommended Posts

Ive recently upgraded my pc and reinstalled windows 7.

Ive installed the m90 driver (m90 setup i noticed that i wasnt able to enable hardware playback and not able to change the dpi of the mouse.


I've googled this and came to the conclusion to reinstall the firmware.


Thing couldnt go more wrong.

Instead of solving the issue the mouse is moving on its own like there is no tomorrow (up down, left right it goes where it pleases).


But i was able to change the hardware playback and dpi... after a reboot these options where gone too.


What to do? ive reflashed the firmware 3 times now (version 1.11).

So far no succes.

Link to comment
Share on other sites

i'll give that a try.


I tried to folllow this links troubleshooting page (http://forum.corsair.com/v3/showthread.php?t=104856) but i dont see corsair as a manufacturer in the list.


Besides that i notices that since to day i think (was just 1 led before) 1 and 6 led a lit up and the other 4 are not. Im no longer able to flash the firmware im gettin a message:

Cannot open USB device, please plug the device into a USB port or reinstall driver!

Link to comment
Share on other sites



but how to follow that steps again, i dont c corsair as a manufacturer in the list.



ï was able to execute dpinst.exe but it didnt change a thing. Mouse is still working with the bottum and upper led lit on but i have the same issues as described as above.

With another mousemat i have slightly better performance but this is not due the mousemat this mouse worked fine on the ohter mousemat for a year of so. All this happend after flashing the firmware to 1.11.

Link to comment
Share on other sites

What ever i do i cant seem to figure this one out.


Trouble shootin ends with trying to select the driver from the alternative list when i try to update the driver.

Corsair is not presented as a manufacturer.

Link to comment
Share on other sites

Manually install the drivers and see if that helps.


Right click the device in Device Manger>Update driver>Browse my computer for software>browse to the M90 firmware updater folder/drivers/OS bit version>Next and see if it install the drivers.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...