Jump to content
Corsair Community

Vengeance 2000 turns of while charging


Recommended Posts

Hi there,

i got the following problem:


If my Veng2k needs to be reloaded it is still in full function for a while but then suddenly turns off.


I first thought its because of the software: I deinstalled the old one, got the newest version and installed it.


After that I tried to stable the loading cable with tape: I doesnt seem to be a loose contact. It even turnd off while not beeing moved at all.


I can of course switch it on again but very often its off again after only seconds. Very often I can hear something like a soft klicking if it happens which is repeating for a while. The light which is showing that it is loading and the little blue one from the "usb stick" is blinking too all the time.


Any ideas what the solution could be?

Link to comment
Share on other sites

When you plug the charging cable in do you see a solid amber light then flashing amber? or only a flashing red light?


If you don't get the solid light first, try a different MicroUSB cable and see if that helps.


Flashing red means the battery is low.

Link to comment
Share on other sites

I have been trying it out for while now and it seems to be the mini usb slot.

The original cable is wiggeling around in it not giving the right contact. My other cable is a bit thicker and fits better. In last case it works... most times...


Therfore i guess the batterie went out of energie with the original cable what makes it turn of but sometimes worked for a while because of having gotten a bit energy.


What I think so far...seems to be a combination of some little issues creating a big problem :(

Link to comment
Share on other sites

Yes, the online shop whre i bought it woulkd be my first step.

But at first I would want to get sure, that there is a real problem which I cant fix by just using an other cable...or whatever ;)

Link to comment
Share on other sites

  • 1 month later...

Okay, i finaly figured out, what the problem might be - but still not knowing it 100%.

Seemed like the cable slot of the headset wasnt fitting right and pushed the plugs contacts deeper inside which made it imposible to connect smoothly.


The company that sold me the article sent it back to Corsair and now its a question of time that i get tow know what happend, why it happend and if they repair it or whatever...


I havnt got clear information about how long it would take - the first 4 weeks are over.

Does anybody know about this?


Or did somone have a similar problem with his phones?




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...