Jump to content
Corsair Community

Can't install win 7 on laptop with P64.


Recommended Posts


For mothers day I've decided to buy my mom a new laptop - the Asus K55A (with i7).

To make sure it runs as fast as possible I've also decided to put my old P64 in it as well but this is giving me trouble.

Basically the bios of the laptop recognizes the SSD, however it won't boot from it.

I've tried multiple things already, such as:

-Using Parted Magic to secure erase the SSD

-Switched between AHCI and IDE with the sata controller

-Done a clean win 7 install on my desktop PC

As it is right now, I think that the sata controller is too slow to pick up the SSD during boot.

Basically what happens is that when the SSD is plugged into the laptop, the laptop has a black screen and nothing happens. When I put the boot priority to my win 7 install disc the same thing happens. But when I remove the SSD and do the same the win 7 disc loads. When I plug the SSD back into the laptop once it starts loading the installer won't recognize the SSD and tells me that there are no drives available.

I'm also aware of the shift + F10 fix that you do during this install but again - the SSD cannot be found.

I do not have this issue on my desktop PC as everything works fine on there and I can do anything with it.

On a final note: The SSD is currently put as IDE.


If you have any suggestions let me know.

Thanks in advance.

Link to comment
Share on other sites

Quick update: This issue seems to be limited to this SSD in particular. I tried plugging in my OCZ vertex 2 (120GB) into it and it instantly booted up and loaded windows.
Link to comment
Share on other sites

you may have to run "fdisk /MBR" on it from like a win98 boot disk. there nmay be another boot signature on it which has nothing to do with the formatting.

you can plug it in to your PC and run fdisk x: /MBR


do a little reading on fdisk first so you dont wipe the wrong drive.


also if you can boot from dvd on the laptop, research the "fixboot" command. this may help as well/

Link to comment
Share on other sites

Could you help me find a proper way to run msdos? I've spent quite some time and failed at it.

Also, I don't have a floppy drive so either a bootable usb or VM workstation is needed.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...