Jump to content
Corsair Community

H100i not installing drivers, and not in link


Recommended Posts

Hey guys,


I've read through the forums on this matter and I can really seem to wade through all the advice.


So what's the current advice for a H100i who's driver aren't installing, and therefore cannot be seen in link.


I've also got a commander system in my PC that working(ish). I've tried the H100i plugged into just the commander, just a USB header, just an external USB and in combinations of USB and commander.


Every time I just get an Unknown Device show up in Device Manager. I'm not sure what firmware it's running, and obviously have no way of checking, not that, that should really make a difference to get it installed in the 1st place!


I should add that it is working, but I am missing half the functionality, but I suppose this is about in line with Link in general.


I really want this range of products to be good, but so far it's just been disappointment after disappointment for me! :(


Hopefully you guys can help me out and cheer me up a bit!!






edit - Just to clarify, while it is working I'm 99% the fans are at 100% since it sounds like I'm sitting about 5m away from a jet engine!


edit 2 - *sigh* and now to add to my woes Link seems to be ignoring me altogether now!!


Get it together Corsair a lot of people have paid a lot of money supporting you over the years, this is not the level of service or quality we have come to expect!

Link to comment
Share on other sites

Just tried it with just the commander unit again and this time the H100i fans don't even work. Which is fun when you're running an overclocked i7 3770k which run rather hot!


Would really appreciate a response here, it's really disheartening to see other people getting help whilst you're just getting ignored!

Link to comment
Share on other sites

First thing I'd suggest is reading the new FAQ sticky at the top of the forum. Sounds to me like the drivers are not getting installed correctly, if at all. Could also be that the mainboard USB drivers need updating; both 2.0 and, on some boards 3.0 as well.
Link to comment
Share on other sites

The drivers are there, because I've got a commander installed. Windows just isn't recognising the h100i and applying the drivers to that.




I've read through that and tried everything on the list. Nothing.


Just tried re installing my usb drivers. Nothing.


Begging to think this might be an RMA job...

Link to comment
Share on other sites

  • Corsair Employees
Do you have an unknown device in Device Manager? If you do, In Device manager, Right click the unknown device and click Uninstall, then scan for hardware changes. If that changes anything.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...