Jump to content
Corsair Community

K90 software - text entry not retained - abysmal


Recommended Posts

I would like to assert my right to technical support, please.


I have K90 keyboard, running v1.00.00.30 software, v1.31 firmware under Win7 x64. (I recently updated the firmware using the package provided by Corsair.)


I'm finding the macro setup application to be completely abysmal.


1) If I try to adjust the values in the following fields, they simply go blank (all text is wiped)

*Assign Keys|Playback Options|Fixed Macro Delay Time

*Assign Keys|Delay Options|(first numeric field)

*Assign Keys|Delay Options|Default delay


2) Any text I type into the Assign Key label field (to the right of the G* > writing) is also deleted upon pressing enter.


3) Only some of the macros will actually play back. I have tried software AND hardware modes to no avail.


4) In the Manage Profiles page, there the text colour of the unselected profile is black... the background is black... Seriously?


To be completely honest, having formerly been a Logitech G110 user (their setup software works exactly as you would expect), I'm quite unimpressed with Corsair's offering, especially since it cost twice as much.

Link to comment
Share on other sites

Post the information screen text by click the "i" icon at the top right hand corner.

Have you tried reinstalling the software?


3. What type of macros are they? If they are ones such as Launch Program, it will not work under hardware playback. Did you save the profile to the K90?

Link to comment
Share on other sites

Hi Toasted, thanks for your reply.



USB Keyboard:

VID: 0x1B1C

PID: 0x1B02

Manufacturer: Corsair

Product: Corsair Vengeance K90 Keyboard

Firmware: 1.31

Windows: Windows 7 Home Premium 64 bit


I have not tried to reinstall the software, but can do that.


3) The macros are simple key combinations (SHIFT+G, CTRL+SHIFT+G, etc)

Link to comment
Share on other sites

Probably a combination, since it's most convenient to click the MR button to start/stop recording while using the control panel application...


ahhh, wait... if the recording is started or stopped with the hardware key, does that mean it's not registered by the software, even if the keyboard is not in Hardware Mode?


I will try this again tomorrow when I'm next at my desk.



I will also reinstall to see if it fixes the 'invisible text' issue.

(P.S. I have WindowBlinds skinning software running, but I have disabled it for all of the Corsair executables.)

Link to comment
Share on other sites

  • Corsair Employees
The best way to do simultaneous key presses (Like CTRL+V) is to ensure you have checked "Ignore Delays" when recording it. Recording it with the keyboard MR button does record it in the software too as long as hardware playback is not enabled.
Link to comment
Share on other sites

Alright guys, I have reinstalled the software (when you attempt to reinstall while it's already installed, the installer prompts you to remove the current version first. Then you run the installer again and this time it will re-install.)


Note: I did not load my previously saved key commands for fear that it might bring the problem with it.


As you can see in the screencap linked below, text entry into the text fields is f%$*ed.





In addition to the very annoying, but trivial text entry problem, this keyboard only plays back SOME macros. I have tried software mode and I have tried hardware mode (after loading presets into the keyboard first).

Still no good. Some macros work, some don't (even though they are all of the same 'complexity' ALT+G doesn't work, but SHIFT+ALT+G works, though CTRL+ALT+S doesn't.)

Any more suggestions before I hurl this back to the dealer?



I traced the issue I was having with the profile screen not showing the profiles to WindowBlinds (skinning software), even though I had disabled it for all Corsair .EXEs.

Once I completely unloaded it, the problem disappeared so I'll accept fault for that one.

Link to comment
Share on other sites

The profiles seem to be fine.


Here's a software that should be able to display keystrokes and mouse clicks.



What software are you using? Have you tried the macros with the delays?


Check Event Viewer and see if there are any entries listed for the Vengeance K90 software that may hint to the error where whatever you type goes blank.

Link to comment
Share on other sites

Hi Toasted,


I have installed osdHotkey and taken a screencap. In the screencap, I click the G key in the Corsair GUI simply to indicate which key I'm pressing on the keyboard.


As you will see, I have used both software and hardware modes, being careful to upload the commands to the keyboard first ("Save to K90").


Most of the commands STILL don't work. Unless you can recommend a fix, I will have to request an RMA from Corsair and return this keyboard for a full refund.

This would be quite disappointing since I'm not looking forward to going back to a Logitech device.



Thanks again for your help,



Too large to attach, hosted on Dropbox:


Link to comment
Share on other sites

Hi Toasted,

I just reflashed the firmware - still no change, but I found the problem... most of my G keys aren't transmitting a signal at all. This is very evident in the Corsair software. Some of the G-key presses register, some don't.


Glad I found the problem, but not impressed that it happened.

Do you know how I organise an RMA? Maybe Corsair will swap for K95

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...