Jump to content
Corsair Community

M90 not being detected at all


Recommended Posts

I bought my M90 a few months ago and everything was working fine until one day it just decided to die. It doesn't light up and none of the buttons work. I unplugged it and plugged it back in to all my usb ports none of them detect the mouse. Tried on several other computers running XP, Windows 7 and Windows 8. My computer is running on Windows 7. I didn't do anything and it just died. Tried to update firmware and it told me that no M90 was detected. Tried to install the software and it told me to plug in the M90. I was a huge fan of corsair but after this experience I'm not so sure anymore. I'm also not happy about the RMA service which you guys offer. I sent a RMA request and in the email it stated "Thank you for contacting Corsair Customer Service.


We have received your request; your ticket # is 6011190. A Customer Service representative will respond within 8 business hours."


It has been 6 days and I have yet to be contacted. I am very unsatisfied with Corsairs product reliability and their customer service. If this doesn't get resolved properly, I'm taking my business elsewhere and that includes my friends whom I've recommended to Corsair recently. If all else fails I'm moving back to steelseries

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...