Jump to content
Corsair Community

Win7 64-bit ultimate: Can't install Vengeance 1500


Recommended Posts

mobo: P8H67-I Deluxe mobo


Works on another PC (detects as HD audio device) but does not detect on this, my main gaming PC. Upon insertion, thinks for a few seconds and fails (red x) Device driver software was not successfully installed.


Clicking for status/details shows "red X no driver found"


In Device Manager, on the device with yellow exclamation mark. Right-click, Properties for details and it goes "no driver found"


The drivers for this device are not installed. (Code 28)

There is no driver selected for the device information set or element.

To find a driver for this device, click Update Driver.


Right-click, Update Driver and pointing it to unpacked contents of 1.1 drivers and browsing to "USB112-110929-8.2150(W7-ER)WHQL\SoftwareDriver" doesn't even work. Having it search online through Windows Update does not find anything either.


Backstory: had a HS1USB for years that I loved. It broke physically with the plastic. Uninstalled v1.1 of Corsair drivers for HS1USB. Bought 2 Creative Sound Blaster Tactics 3D Sigma USB headsets--they didn't detect either upon insertion of the USB dongle. Returned first one, tried another. No dice either. Before or after installation of Creative.


Bought a Corsair Vengeance 1500. Same problem so figured my USB device was broken not the 2 Tactic 3D headsets or the Corsair. Obviously, my Windows 7's ability to detect/identify USB devices is bjorked. Existing devices work still. For now.


WORKAROUND: I can override driver install with "Let me pick a list of device drivers" and choose the category of "Sound, video, game controller" and then point it to the 1.1 driver. I then get sound.


HOWEVER, the Corsair program installer (InstallShield) will still fail (after the Vengeance 1500 is installed by the above workaround) with just:


Install error: The system has not been modified.


Finding CMInstall.log in C:\windows\temp\ shows only


install failed!


This is driving me nuts. I've tried uninstalling KB2709162, clean booted, tried different usb powers, hub, not-on-hub, powered off PC to discharge electricity, blahblahblah, emptying the driverstore, rebooting, deleting upper and lower filters but at this point I'm resigned to not fixing my detection issue and settling for the ability to forcefully install the Corsair-customized C-Media system tray software if that's at all possible. :(


Is there a way to force installation of the system tray Corsair software?

Link to comment
Share on other sites

v2.07 of the headset software (yes, I know it was buggy for 1500) installs since it's a standalone MSI/installer. Is it possible to post the v1.1 version of the Corsair/C-Media software unbundled from the 1.1 drivers?
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...